Bug 67596 - Multiple use of --relocate doesn't work
Multiple use of --relocate doesn't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
: 62011 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-27 17:54 EDT by Lloyd Parkes
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-27 17:54:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lloyd Parkes 2002-06-27 17:54:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
The manual page for rpm says that I can use --relocate multiple times to 
relocate multiple paths. When I try I get the following two types of response

[root@newns1 RPMS]# rpm -i --relocate=/usr/share=/u01/htdig/htdocs --
relocate=/var/lib=/var/db htdig-3.2.0-2.011302.i386.rpm
path #@7I7 in package htdig-3.2.0-2.011302 is not relocateable
path /var/lib in package htdig-3.2.0-2.011302 is not relocateable

Note the corrupt path name in the first error message.

When --badreloc is added I get the following

[root@newns1 RPMS]# rpm -i --badreloc --relocate=/usr/share=/u01/htdig/htdocs --
relocate=/var/lib=/var/db htdig-3.2.0-2.011302.i386.rpm
[root@newns1 RPMS]# rpm -ql htdig | egrep 'var|index.html'
/usr/share/doc/htdig-3.2.0/cf_variables.html
/usr/share/doc/htdig-3.2.0/confindex.html
/usr/share/doc/htdig-3.2.0/index.html
/usr/share/htdig/index.html
/var/db/htdig

Note that only the last --relocate has worked. If I reorder the --relocate 
options in the command line, it is still only ever the last --relocate that is 
used.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -i --relocate=/usr/share=/u01/htdig/htdocs --relocate=/var/lib=/var/db 
htdig-3.2.0-2.011302.i386.rpm
2.rpm -i --badreloc --relocate=/usr/share=/u01/htdig/htdocs --
relocate=/var/lib=/var/db htdig-3.2.0-2.011302.i386.rpm
3.rpm -ql htdig | egrep 'var|index.html'
	

Actual Results:  path #@7I7 in package htdig-3.2.0-2.011302 is not relocateable
path /var/lib in package htdig-3.2.0-2.011302 is not relocateable

/usr/share/doc/htdig-3.2.0/cf_variables.html
/usr/share/doc/htdig-3.2.0/confindex.html
/usr/share/doc/htdig-3.2.0/index.html
/usr/share/htdig/index.html
/var/db/htdig


Expected Results:  path /usr/share in package htdig-3.2.0-2.011302 is not 
relocateable
path /var/lib in package htdig-3.2.0-2.011302 is not relocateable

/u01/htdig/htdocs/doc/htdig-3.2.0/cf_variables.html
/u01/htdig/htdocs/doc/htdig-3.2.0/confindex.html
/u01/htdig/htdocs/doc/htdig-3.2.0/index.html
/u01/htdig/htdocs/htdig/index.html
/var/db/htdig

Additional info:

[root@newns1 RPMS]# rpm -q rpm
rpm-4.0.4-7x.18

Also occurred in rpm 4.0.3.
Comment 1 Jeff Johnson 2002-06-28 09:04:02 EDT
CLI arg passed to popt callback was free'd,
yuk.

Fixed in rpm-4.1-0.35.
Comment 2 Jeff Johnson 2002-06-28 12:09:53 EDT
*** Bug 62011 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.