Bug 676300 - RFE: support more than 32 evdev minors
Summary: RFE: support more than 32 evdev minors
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 824657 (view as bug list)
Depends On:
Blocks: 734812
TreeView+ depends on / blocked
 
Reported: 2011-02-09 12:05 UTC by Alexander Todorov
Modified: 2013-11-23 20:52 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 734812 (view as bug list)
Environment:
Last Closed: 2013-11-23 20:52:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Linux Kernel 28682 None None None Never

Description Alexander Todorov 2011-02-09 12:05:28 UTC
Description of problem:

This is tracker to follow https://bugzilla.kernel.org/show_bug.cgi?id=28682

I've managed to reach the 32 evdev devices limit on a big multi-seat system. Growing the system further is limited by this fact. Would love to see this fixed in Fedora and then backported to RHEL.

Comment 1 Jerome 2012-05-23 22:24:18 UTC
We've had a customer report this issue and have recreated it.

More detail at:

http://support.plugable.com/plugable/topics/multipoint_server_2011_on_multiple_pcs?utm_content=topic_link&utm_medium=email&utm_source=reply_notification

Comment 2 Michal Schmidt 2012-05-29 16:29:56 UTC
*** Bug 824657 has been marked as a duplicate of this bug. ***

Comment 3 Michele Baldessari 2013-11-23 20:52:13 UTC
This has been included last year via:
commit 7f8d4cad1e4e11a45d02bd6e024cc2812963c38a
Author: Dmitry Torokhov <dmitry.torokhov@gmail.com>
Date:   Mon Oct 8 09:07:24 2012 -0700

    Input: extend the number of event (and other) devices
    
    Extend the amount of character devices, such as eventX, mouseX and jsX,
    from a hard limit of 32 per input handler to about 1024 shared across
    all handlers.
    
    To be compatible with legacy installations input handlers will start
    creating char devices with minors in their legacy range, however once
    legacy range is exhausted they will start allocating minors from the
    dynamic range 256-1024.
    
    Reviewed-by: David Herrmann <dh.herrmann@googlemail.com>
    Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>

v3.7 was the first kernel with this. Closing this.

Alexander, could you close the kernel.org BZ as well please?

thanks,
Michele


Note You need to log in before you can comment on or make changes to this bug.