Bug 676365 - Verizon UMW190 modem recognizes as GSM (not CDMA)
Verizon UMW190 modem recognizes as GSM (not CDMA)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ModemManager (Show other bugs)
6.1
All Linux
medium Severity medium
: rc
: 6.1
Assigned To: Dan Williams
Desktop QE
: OtherQA
Depends On:
Blocks: 637248 782183 840699
  Show dependency treegraph
 
Reported: 2011-02-09 11:27 EST by Matthew Mosesohn
Modified: 2013-03-12 16:05 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 16:05:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ModemManager patch (2.39 KB, patch)
2011-05-18 14:43 EDT, Jacob Hunt
no flags Details | Diff
Allow users to prefer CDMA mode on multimode devices via /etc/mm-multimode-prefer-cdma (1.05 KB, patch)
2012-07-20 17:32 EDT, Dan Williams
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 657136 None None None Never

  None (edit)
Description Matthew Mosesohn 2011-02-09 11:27:12 EST
Description of problem:
This modem has both GSM and CMDA capability.  This is a ModemManager bug already fixed upstream.  ModemManager can't handle Pantech dual-radio modems properly, and only tolerates the GSM portion which will not operate in the US.

Version-Release number of selected component (if applicable):
ModemManager-0.4.0-3.git20100628.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Plug in UMW190 modem
2. Eject the CD device it creates

  
Actual results:
NetworkManager/ModemManager sets up device as GSM and it can't be switched to CDMA

Expected results:
The modem should allow user to override and choose CDMA setup, or detect device properly.

Additional info:
related bug
https://bugs.launchpad.net/ubuntu/+source/modemmanager/+bug/657136
Comment 2 RHEL Product and Program Management 2011-02-09 11:48:25 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 Jacob Hunt 2011-05-18 14:43:17 EDT
Created attachment 499663 [details]
ModemManager patch
Comment 6 RHEL Product and Program Management 2011-07-12 11:58:53 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 7 Matthew Mosesohn 2011-08-16 12:27:40 EDT
Can this be considered for 6.2 or be marked for 6.3?
Comment 12 RHEL Product and Program Management 2012-07-10 02:54:25 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 13 RHEL Product and Program Management 2012-07-10 20:00:57 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 15 Dan Williams 2012-07-20 17:20:10 EDT
Also, proper support for this device would also require adding its IDs to the 'qcaux' driver in the kernel, so we can get signal strength and registration state while the device is connected using PPP on the primary TTY.
Comment 16 Dan Williams 2012-07-20 17:32:38 EDT
Created attachment 599465 [details]
Allow users to prefer CDMA mode on multimode devices via /etc/mm-multimode-prefer-cdma

Touching /etc/mm-multimode-prefer-cdma will make the modems be recognized as CDMA devices instead of GSM.
Comment 17 Dan Williams 2012-07-20 17:34:33 EDT
Hah, ok, for the RHEL6 kernel qcaux doesn't exist.  I suppose we can add the USB IDs for these devices to option, but backporting qcaux might be a better choice in the long run.  But that's for the kernel team to decide.

Note You need to log in before you can comment on or make changes to this bug.