Bug 676484 - There is no indication of full preallocation mode in qemu-img man page
There is no indication of full preallocation mode in qemu-img man page
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.1
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
: ManPageChange, Triaged
Depends On:
Blocks: 580953
  Show dependency treegraph
 
Reported: 2011-02-09 21:16 EST by Shirley Zhou
Modified: 2015-03-04 19:52 EST (History)
7 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.238.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 07:32:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shirley Zhou 2011-02-09 21:16:22 EST
Description of problem:
Check man page of qemu-img, there is no indication of "full" preallocation mode.

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.144.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. #man qemu-img , search preallocation mode,get 

"preallocation"
Preallocation mode (allowed values: off, metadata). An image with preallocated metadata is initially larger but can improve performance when the image needs to grow.

  
Actual results:
no full mode indicate.

Expected results:
There should be indicated full preallocation mode.

Additional info:
Comment 2 Dor Laor 2011-02-13 07:52:08 EST
Kevin, it seems like a nice to have
Comment 7 juzhang 2012-03-09 04:05:16 EST
Verified with qemu-kvm-0.12.1.2-2.240.el6.x86_64

 "preallocation"
               Preallocation mode (allowed values: off, metadata, full). An image with preallocated metadata is initially larger but can
               improve performance when the image needs to grow. Full preallocation additionally writes zeros to the whole image in order to
               preallocate lower layers (e.g. the file system containing the image file) as well. Note that full preallocation writes to
               every byte of the virtual disk, so it can take a long time for large images
Comment 9 Dor Laor 2012-04-22 07:32:36 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed
Comment 10 errata-xmlrpc 2012-06-20 07:32:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0746.html

Note You need to log in before you can comment on or make changes to this bug.