Bug 676698 - authconfig breaks mdns
authconfig breaks mdns
Status: CLOSED DUPLICATE of bug 645295
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2011-02-10 15:16 EST by Jeff Bastian
Modified: 2011-02-10 15:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-02-10 15:45:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2011-02-10 15:16:17 EST
Description of problem:
I use mDNS (Zeroconf/Avahi/Bonjour/etc) on my home network.  My /etc/nsswitch.conf contains:
    hosts:      files mdns4_minimal [NOTFOUND=return] dns

I was testing SSSD and I ran
    authconfig --enablesssd --enablesssdauth --enablecachecreds --update
to enable SSSD in my nsswitch.conf and pam config.  That worked, but at the same time, it removed mdns4_minimal from my hosts settings.  My nsswitch.conf only contained the basic
    hosts:      files dns
after running authconfig.

Please preserve mdns4_minimal when running authconfig.

Version-Release number of selected component (if applicable):

How reproducible:
every time

Steps to Reproduce:
1. if necessary, install nss-mdns
2. verify mdns4_minimal is listed in /etc/nsswitch.conf for hosts
3. authconfig --enablesssd --enablesssdauth --enablecachecreds --update
Actual results:
mdns4_minimal is stripped from nsswitch.conf for hosts

Expected results:
mdns4_minimal is preserved

Additional info:
The nss-mdns post-install scriptlet adds mdns4_minimal to nsswitch.conf:
$ rpm -q --scripts nss-mdns
postinstall scriptlet (using /bin/sh):
# Perl-fu to add mdns4_minimal to the hosts line of /etc/nsswitch.conf
if [ -f /etc/nsswitch.conf ] ; then
        sed -i.bak '
                /^hosts:/ !b
                /\<mdns\(4\|6\)\?\(_minimal\)\?\>/ b
                s/\([[:blank:]]\+\)dns\>/\1mdns4_minimal [NOTFOUND=return] dns/g
                ' /etc/nsswitch.conf
Comment 1 Tomas Mraz 2011-02-10 15:26:14 EST
This is fixed in the current version in rawhide.
Comment 2 Jeff Bastian 2011-02-10 15:45:44 EST
I see now this is a duplicate of 645295.

I searched bugzilla for "authconfig mdns4_minimal" before opening this and nothing showed up.  Argh.  Sorry for opening a duplicate.

*** This bug has been marked as a duplicate of bug 645295 ***

Note You need to log in before you can comment on or make changes to this bug.