Bug 67682 - Input in Big5 doesn't support in miniChinput
Input in Big5 doesn't support in miniChinput
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: miniChinput (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Yu Shao
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-29 00:53 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-14 19:56:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-06-29 00:53:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
I have set all environment variables that is needed to view and type in Big5.

After I do "chinput -big5", I try to type chinese characters in an application,
let's say GAIM. It shows the characters in a little float window with
traditional chinese characters in PINYIN mode. So there is no problem viewing it
in Big5. The problem is that when I have selected a character, it doesn't input
the character for you. Note that this situation doesn't happen when I am in GB
mode. Please also note that I can input in Big5 with RedHat 7.2. I have also
tried miniChinput-0.0.3-21pre1.rpm but it also won't work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Fire up a bash shell. Type in the following:
2.export LANG=zh_TW.Big5;
3.export LC_CTYPE=zh_TW.Big5;
4.export XMODIFIERS="@im=Chinput";
5.chinput -big5
6.gaim or mozilla
7.switch mode to PINYIN
8.type 'ta'
9.select any character, say 1
	

Actual Results:  Chinput won't input any character for you.

Expected Results:  A chinese character in big5

Additional info:
Comment 1 Yu Shao 2002-06-29 09:03:12 EDT
This is a known bug.
Comment 2 Need Real Name 2002-06-29 12:36:39 EDT
Is there any solution that allowed me to input characters in big5 with pinyin?
Comment 3 Yu Shao 2002-07-07 22:37:09 EDT
What about you use locale_config change the current locale to big5, and restart
X, you will be able to use xcin at this point, cause xcin is the default IM for it.

Anyway, I am working on it, thank you for the report!
Comment 4 Need Real Name 2002-07-08 15:39:26 EDT
One nice thing I found about chinput was that I could use "Zhi Neng Pin Yin"
under chinput in big5. What I did was to modify Chinput.ad, under the section of
[ZNPY], I set the encoding to BIG5. Although some characters may appear blank(no
traditional characters that are corresponding to the particular simplified
characters), it does pretty much what I want. Please note that this doesn't work
anymore in RH 7.3, except RH 7.2.
Comment 5 Yu Shao 2002-07-08 20:59:10 EDT
Download new packages from here: http://people.redhat.com/yshao/miniChinput/

miniChinput-0.0.3-22.1 is for 7.3, 
miniChinput-0.0.3-23 is for Red Hat Beta Limbo.




Comment 6 Need Real Name 2002-07-14 11:30:04 EDT
Thank you for fixing it. It works perfect now! I'm also amazed by having
anti-alias font. I just love it!

Note You need to log in before you can comment on or make changes to this bug.