Bug 67702 - CGI script and Virtual Domains don't work together
CGI script and Virtual Domains don't work together
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.3
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-29 22:28 EDT by David
Modified: 2007-03-26 23:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 06:41:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David 2002-06-29 22:28:38 EDT
Description of Problem: I found that since the update that I am unable to run 
CGI commands at the same time I have virtual hosts enabled.  If I comment all 
my virtual host files, I can run the CGI scripts (I.E. 
mail.thedarktrumpet.com/cgi-bin/webmail).  If I attempt to run the CGI with 
virtual domains I get the following HTTP error when trying to browse it:

---BEGIN SNIP
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to 
complete your request.
Please contact the server administrator, root@thedarktrumpet.com and inform 
them of the time the error occurred, and anything you might have done that may 
have caused the error.

More information about this error may be available in the server error log.



-------------------------------------------------------------------------------
-

Apache/1.3.23 Server at rjh.thedarktrumpet.com Port 80

---End SNIP

My error log shows the following segment:
--Begin Snip
[Sat Jun 29 20:26:47 2002] [error] [client 12.217.30.35] (2)No such file or 
directory: getpwuid: invalid userid -1
[Sat Jun 29 20:26:47 2002] [error] (2)No such file or directory: exec 
of /var/www/cgi-bin/webmail failed
[Sat Jun 29 20:26:47 2002] [error] [client 12.217.30.35] Premature end of 
script headers: /var/www/cgi-bin/webmail
--END Snip

The config file is set for user Apache and Group Apache.  User Apache exists.


Version-Release number of selected component (if applicable):
Server version: Apache/1.3.23 (Unix)  (Red-Hat/Linux)
Server built:   Jun 19 2002 11:55:23

How Reproducible:
Update apache to the highest settings, use any CGI (i made one also to test 
out), and make a virtual domain and try to browse to the CGI.

Steps to Reproduce:
1. In section "How Reproducible"

Actual Results:
Output above in the log and on the page.

Expected Results:
The ability to show the CGI as expected.


Additional Information:
This worked until the update.  I haven't edited anything.
Comment 1 Joe Orton 2004-09-21 06:41:08 EDT
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

Note You need to log in before you can comment on or make changes to this bug.