Bug 677169 - REGRESSION: qemu-kvm crash (assertion) when guest loads QXL driver
REGRESSION: qemu-kvm crash (assertion) when guest loads QXL driver
Status: CLOSED DUPLICATE of bug 681220
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-13 15:40 EST by Ian Pilcher
Modified: 2013-01-09 06:45 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-07 17:19:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Pilcher 2011-02-13 15:40:16 EST
Description of problem:
I've been running a KVM/SPICE Windows XP guest since Fedora 12 or so -- not
using libvirt, just a script that calls qemu-kvm directly.  There have been
a couple of bumps in the road (SPICE protocol change and qemu syntax change),
but nothing I haven't been able to figure out ... until now.

With the recent Rawhide update, I can't run any SPICE guest.  qemu-kvm
crashes hard, apparently when the guest tries to load the QXL driver.

Version-Release number of selected component (if applicable):
qemu-kvm-0.14.0-0.1.201102107aa8c46.fc15.x86_64

How reproducible:
100%

Steps to Reproduce:
1.  Attempt to run KVM guest that uses spice (exact command below).
  
Actual results:
qemu-kvm: /builddir/build/BUILD/qemu-kvm-0.14.0/qemu-kvm.c:1724: kvm_mutex_unlock: Assertion `!cpu_single_env' failed.

Expected results:
No crash.  Should work.

Additional info:
Here is the script that I use to start my guest:

#!/bin/bash

/usr/bin/sudo /usr/sbin/tunctl -p -t xpspice0 -u pilcher -g pilcher
/usr/bin/sudo /sbin/ifup xpspice0

/usr/bin/sudo /bin/chown pilcher:pilcher /dev/root_vg/xp-spice_vm_lv

/home/pilcher/bin/slow-spice.sh --host localhost --port 5930 &

/usr/bin/qemu-kvm -M pc -m 512 -smp 1 -name xp-spice -localtime \
    -monitor unix:/tmp/qemu-monitor-xp-spice,server,nowait \
    -usb -usbdevice tablet -soundhw ac97 -serial none \
    -parallel none -uuid 6db12eb3-2473-4ffb-8079-02ff40d52cd0 \
    -vga qxl -spice port=5930,disable-ticketing \
    -drive file=/dev/root_vg/xp-spice_vm_lv,if=virtio,index=0,boot=on,cache=none \
    -net nic,model=virtio,macaddr=54:52:00:5f:bb:7f,vlan=0,name=nic.0 \
    -net tap,name=tap.0,ifname=xpspice0,vlan=0,script=no,downscript=no

/usr/sbin/tunctl -d xpspice0

Here is slow-spice.sh:

#!/bin/bash
/bin/sleep 1
/usr/bin/spicec $@
Comment 1 Jason D. Clinton 2011-02-14 11:50:41 EST
Same here.
Comment 2 Douglas Kieweg 2011-02-15 16:15:35 EST
I have the same problem with: 

Name        : qemu-kvm                     Relocations: (not relocatable)
Version     : 0.14.0                            Vendor: (none)
Release     : 0.1.201102107aa8c46.fc14      Build Date: Fri 11 Feb 2011 12:06:51 PM CST
Install Date: Fri 11 Feb 2011 02:16:07 PM CST      Build Host: fedora64.linuxtx.org
Group       : Development/Tools             Source RPM: qemu-0.14.0-0.1.201102107aa8c46.fc14.src.rpm
Comment 3 Ian Pilcher 2011-03-02 18:54:53 EST
Are the latest batch of SPICE-related updates expected to address this?
Comment 4 Mikhail Kulemin 2011-03-04 03:18:26 EST
Yes. I use qemu-kvm-0.14.0-2.fc14.x86_64 from fedora-virt-preview and spice-0.8.0. 

command line
sudo qemu-kvm -m 2000 -drive file=/dev/vg_virt/win -name test -vga qxl -soundhw ac97 -monitor stdio -balloon virtio -spice port=$3,disable-ticketing -usb -usbdevice tablet -smp 1 -net nic,model=virtio,vlan=0 -net tap,vlan=0,ifname=test -boot c -enable-kvm

Error:
qemu-kvm: /builddir/build/BUILD/qemu-kvm-0.14.0/qemu-kvm.c:1724: kvm_mutex_unlock: Assertion `!cpu_single_env' failed.
Comment 5 Mikhail Kulemin 2011-03-04 06:00:29 EST
Qemu 0.14.0 build with sources from http://download.savannah.gnu.org/releases/qemu/qemu-0.14.0.tar.gz works fine.
Comment 6 Paul Jenner 2011-03-04 16:16:09 EST
Duplicate of bug #681220 - qemu-kvm-0.14.0/qemu-kvm.c:1724: kvm_mutex_unlock:
Assertion `!cpu_single_env' failed ?
Comment 7 Jason D. Clinton 2011-03-07 16:17:15 EST
Still blows up with latest spice-server packages.
Comment 8 Ian Pilcher 2011-03-07 17:19:55 EST
(In reply to comment #6)
> Duplicate of bug #681220 - qemu-kvm-0.14.0/qemu-kvm.c:1724: kvm_mutex_unlock:
> Assertion `!cpu_single_env' failed ?

Well, I opened this bug first, so it's technically a duplicate of this.  ;-)
That one has a patch in it, though, so I'm going to go ahead and close this
as a dupe.

*** This bug has been marked as a duplicate of bug 681220 ***

Note You need to log in before you can comment on or make changes to this bug.