Bug 67721 - kernel-2.4.18-5.58 BUG at page_alloc.c:127
kernel-2.4.18-5.58 BUG at page_alloc.c:127
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-30 22:08 EDT by Ricardo Ariel Gorosito
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-01 23:04:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ricardo Ariel Gorosito 2002-06-30 22:08:24 EDT
Description of problem:
I was noted that runing X, the amount of memory used was increased.
~ 20Hours uptime, kernel dump:
Jun 30 21:59:22 localhost kernel: ------------[ cut here ]------------
Jun 30 21:59:22 localhost kernel: kernel BUG at page_alloc.c:141!
Jun 30 21:59:22 localhost kernel: invalid operand: 0000
Jun 30 21:59:22 localhost kernel: sr_mod emu10k1 ac97_codec sound soundcore
agpgart NVdriver vmnet vmmon w83781
d
Jun 30 21:59:22 localhost kernel: CPU:    0
Jun 30 21:59:22 localhost kernel: EIP:    0010:[<c0139c0f>]    Tainted: PF
Jun 30 21:59:22 localhost kernel: EFLAGS: 00013286
Jun 30 21:59:22 localhost kernel: 
Jun 30 21:59:22 localhost kernel: EIP is at __free_pages_ok [kernel] 0xbf
(2.4.18-5.58)
Jun 30 21:59:22 localhost kernel: eax: ca7e31d8   ebx: c12ea6d8   ecx: c1000030
  edx: 00000000
Jun 30 21:59:22 localhost kernel: esi: 00000000   edi: 00000000   ebp: cab3debc
  esp: cab3de84
Jun 30 21:59:23 localhost kernel: ds: 0018   es: 0018   ss: 0018
Jun 30 21:59:23 localhost kernel: Process X (pid: 24406, stackpage=cab3d000)
Jun 30 21:59:23 localhost kernel: Stack: c03b7560 cab3deac c013b29d c03b7560
00000000 00000001 00000001 c12ea6d
8 
Jun 30 21:59:23 localhost kernel:        00000000 00001000 c12ea6d8 c25de09c
00000000 00001000 cab3dee8 c012e2f
4 
Jun 30 21:59:23 localhost kernel:        c12ea6d8 cccc64b4 c562c080 082f5568
0d543067 00000001 40400000 c562c40
4 
Jun 30 21:59:23 localhost kernel: Call Trace: [<c013b29d>]
remove_exclusive_swap_page [kernel] 0xbd 
Jun 30 21:59:23 localhost kernel: [<c012e2f4>] zap_pte_range [kernel] 0xf4 
Jun 30 21:59:23 localhost kernel: [<c012c8fa>] do_zap_page_range [kernel] 0x9a 
Jun 30 21:59:23 localhost kernel: [<c012ce2a>] zap_page_range [kernel] 0x5a 
Jun 30 21:59:23 localhost kernel: [<c012f5f6>] do_munmap [kernel] 0x1f6 
Jun 30 21:59:23 localhost kernel: [<c012f74c>] sys_munmap [kernel] 0x8c 
Jun 30 21:59:23 localhost kernel: [<c01092c3>] system_call [kernel] 0x33 
Jun 30 21:59:24 localhost kernel: 
Jun 30 21:59:24 localhost kernel: 
Jun 30 21:59:24 localhost kernel: Code: 0f 0b 8d 00 e3 a5 25 c0 c6 43 24 05 8b
43 18 89 f9 89 de 83 

Additional Info: I use non-RedHat kernel modules: NVidia, VMware & lm_sensors
Comment 1 Bill Nottingham 2002-07-01 14:52:43 EDT
Does the bug persist without any of those drivers loaded since you boot?
Comment 2 Ricardo Ariel Gorosito 2002-07-01 23:04:00 EDT
I'll test this tomorrow (today I can't boot).
FYI: With 2.4.18 (Linus) and those drivers loaded, system work fine.
Comment 3 Arjan van de Ven 2002-07-03 07:30:54 EDT
This is a KNOWN nvidia bug.
This page_alloc bug is the typical signature of nvidia's module corrupting
memory....

Note You need to log in before you can comment on or make changes to this bug.