Bug 67722 - gnome-terminal does not render line drawing characters as expected
gnome-terminal does not render line drawing characters as expected
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.3
All Linux
low Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-30 22:10 EDT by Michael Wardle
Modified: 2007-03-26 23:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-13 21:37:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Wardle 2002-06-30 22:10:29 EDT
Description of problem:
When using GNOME Terminal to access a remote FreeBSD host and run
the system installation and configuration utility /stand/sysinstall),
line drawing characters are rendered incorrectly.  Where a box was
expected, letters appear in place, similar to:

 lqqqqqk
 x     x
 x     x
 mqqqqqj

I have tried setting the terminal type to vt100, vt102, xterm, and
xterm-color using the TERM environment variable.  I have tried
various fixed and proportional fonts.  I have tried disabling any
GUI-configurable internationalization options.

The box is rendered as expected when I use the versions of xterm
and rxvt that ship with the system, as it is with other vt100/xterm
terminal emulation programs such as PuTTY on Windows 2000.

I don't think the remote host has a custom termcap/terminfo entry
for gnome-terminal, but one should not be necessary.


How reproducible:
Always

Steps to Reproduce:
1.log into a Red Hat system :-)
2.run GNOME Terminal from the panel
3.connect to a host running FreeBSD using ssh
4.execute /stand/sysinstall


Actual Results:  Dialogs appear using letters as the box borders.

Expected Results:  Dialogs appear using line drawing characters as the box 
borders.

Additional info:

LOCAL
Red Hat Linux 7.3/x86
gnome-core 1.4.0.4-38
rxvt 2.7.6-4
XFree86 4.2.0-8

REMOTE
FreeBSD 4.5-RELEASE/i386

Excerpt from sysinstall manual page:
-----
sysinstall currently uses the dialog(3) library to do user interaction
with simple ANSI line graphics, color support for which is enabled by
either running on a syscons VTY or some other color-capable terminal
emulator (newer versions of xterm will support color when using the
``xterm-color'' termcap entry).
-----

FreeBSD manual pages are available at
<URL:http://www.freebsd.org/cgi/man.cgi>
Comment 1 Michael Wardle 2002-06-30 22:31:20 EDT
Probably a duplicate of bug 29312.

A few threads on mailing lists suggest that an "ANSI" font is necessary, but
there does not seem to be any ANSI fonts available on Red Hat 7.3.

Perhaps Red Hat could include an ANSI character set typeface in a future
release if this fixes the problem.
Comment 2 Havoc Pennington 2002-07-01 22:48:51 EDT
This is most likely addressed in Rawhide.
Comment 3 Havoc Pennington 2002-12-13 21:37:09 EST
8.0 should have resolved this issue. If not rawhide almost certainly has.
Give it a try. (Totally different terminal codebase.)
Comment 4 Michael Wardle 2002-12-15 17:00:37 EST
I now see the expected behavior using Red Hat Linux 8.0.
Tested using Courier, Luxi Mono, and Andale Mono fonts.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.