Bug 67727 - upgrade install only finds part of swap space
upgrade install only finds part of swap space
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-01 03:28 EDT by Douglas Wooster
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-13 16:43:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas Wooster 2002-07-01 03:28:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.3 (X11; Linux i686; U;) Gecko/20020523

Description of problem:
I have 5 swap partitions of 128MB each, spread over multiple IDE hard drives.  I
have 256MB RAM.  I am upgrading from RH Linux 6.1+ to 7.3.

During the install, anaconda only found 1 of 5 swap partitions and tried very
hard to talk me into creating yet more swap space.

Red Hat support was also able to reproduce this problem several times.  

This was originally service request 206022.  I was told to report this problem here.


Version-Release number of selected component (if applicable):


How reproducible:
Always
This problem was also reproduced by Red Hat support (see Service Request 206022)


Steps to Reproduce:
1.Perform an Upgrade install of RH Linux 7.3.
2.Get to the Swap Space panel.
3.Panel reports that it only finds 128MB of swap space and wants to create a
swap file in the / partition of 350 or so MB.  It claims that there is
insufficient swap space available, and that the installation will crash.
4.Select not to create the swap file.
5.Get another bogus warning that there is insufficient swap space, and
installation is expected to crash.
6.Ignore the warning.
7.Finish installation.
8.Reboot system.
9.All 5 original swap partitions are found and used.
	

Actual Results:

The install program failed to find 4 swap partitions and demanded to create a
very large swap file in the root partition, on pain of the installation dying
for lack of virtual storage.

In fact, the installation did not run out of virtual storage.


Expected Results:

1.  The installation program should have located all of the available swap
partitions.  It could have done this either by scanning the partition tables of
the IDE hard drives or by scanning /etc/fstab .
2.  The installation program should not have tried to create a new swap file.
3.  The installation program should not have claimed that the install would run
out of virtual storage, when 384MB of virtual storage was available.


Additional info:

Expected result 3 is probably covered by bug report 64481.
Expected results 1 and 2 are not currently discussed by bug report 64481.
Comment 1 Michael Fulbright 2002-07-01 16:07:45 EDT
Thanks for the report assigning to an engineer.
Comment 2 Michael Fulbright 2002-10-03 15:30:06 EDT
I could not reproduce this issue with the final 8.0 release.

Could you give the list output from parted for each of the drives in the system?
It seems that libparted is not detected the swap partitions as swap for some
reason on your box.
Comment 3 Douglas Wooster 2002-10-13 04:30:42 EDT
 Sure.  Thanks for working on this.  Here's the output: 
 
GNU Parted 1.4.24 
Copyright (C) 1998, 1999, 2000, 2001, 2002 Free Software Foundation, Inc. 
This program is free software, covered by the GNU General Public License. 
 
This program is distributed in the hope that it will be useful, but WITHOUT 
ANY WARRANTY; without even the implied warranty of 
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General 
Public License for more details. 
 
Using /dev/hdc 
Information: The operating system thinks the geometry on /dev/hdc is 
2434/255/63.  Therefore, cylinder 1024 ends at 8032.499M. 
(parted) print 
Disk geometry for /dev/hdc: 0.000-19092.937 megabytes 
Disk label type: msdos 
Minor    Start       End     Type      Filesystem  Flags 
1         15.688  19092.875  extended 
5         15.719   5137.976  logical   ext2        boot 
6       5138.007   5490.966  logical   ext2        boot 
7       5490.998   6479.340  logical   ext2        boot 
8       6479.372   7506.936  logical   ext2        boot 
9       7506.967   9562.126  logical   ext2        boot 
10      9562.157   9695.478  logical   linux-swap  boot 
11      9695.509   9797.453  logical   ext2        boot 
12     13970.619  19092.875  logical               boot 
(parted) select /dev/hdd 
 
Using /dev/hdd 
Warning: The operating system thinks the geometry on /dev/hdd is 4982/255/63.  
Therefore, cylinder 1024 ends at 8032.499M.  You have 
Windows FAT partition(s) that are not using LBA.  If your BIOS supports LBA, 
then you should switch to LBA by setting the LBA flag on 
all FAT partitions.  Otherwise, make sure the operating system and the BIOS 
have the same geometry before resizing any FAT partitions. 
(parted) print 
Disk geometry for /dev/hdd: 0.000-39083.625 megabytes 
Disk label type: msdos 
Minor    Start       End     Type      Filesystem  Flags 
1         15.688  39079.995  extended 
5         15.719    517.719  logical   FAT         boot 
7        517.750    651.071  logical   linux-swap  boot 
8        651.103    784.423  logical   linux-swap  boot 
9        784.455    917.775  logical   linux-swap  boot 
10       917.807   1051.127  logical   linux-swap 
6       1074.691  39079.995  logical               boot 
(parted) select /dev/hdb 
Error: Error opening /dev/hdb: No medium found 
Retry Cancel ? cancel 
(parted) select /dev/hda 
 
Using /dev/hda 
Warning: The operating system thinks the geometry on /dev/hda is 1662/255/63.  
Therefore, cylinder 1024 ends at 8032.499M.  You have 
Windows FAT partition(s) that are not using LBA.  If your BIOS supports LBA, 
then you should switch to LBA by setting the LBA flag on 
all FAT partitions.  Otherwise, make sure the operating system and the BIOS 
have the same geometry before resizing any FAT partitions. 
(parted) print 
Disk geometry for /dev/hda: 0.000-13042.968 megabytes 
Disk label type: msdos 
Minor    Start       End     Type      Filesystem  Flags 
3      0.031      7.844  primary   FAT         boot 
2          7.844    313.769  primary 
1        313.770  13037.124  extended 
5        313.800    368.679  logical   ext2        boot 
6        368.710    486.342  logical   FAT         boot 
7        486.374    643.227  logical               boot 
8        643.258    847.177  logical               boot 
9        847.208    909.931  logical               boot 
10       909.962   1341.364  logical   ext2        boot 
11      1341.396   1364.897  logical   FAT         boot 
12      1364.928   1396.274  logical               boot 
13      1396.305   4400.617  logical               boot 
14      4400.648   7397.116  logical   ext2        boot 
15      7397.147   7404.960  logical               boot 
16      7404.992  13037.124  logical               boot 
(parted) quit 
 
Note:  /dev/hdb is the CD-ROM drive. 
 
Please let me know if there's anything else you need. 
 
Regards, 
Douglas
Comment 4 Michael Fulbright 2003-03-13 16:43:53 EST
I would recommend just ignoring the installer telling you to make more swap
space, and then see once you've upgraded if the additional swap shows up in
/proc/swaps once you've rebooted.

If not then you can run mkswap on each of the ones which do not show up and reboot .

Also make sure each one shows up in your /etc/fstab.

Note You need to log in before you can comment on or make changes to this bug.