Bug 67739 - fileutils installation fails because of info files
fileutils installation fails because of info files
Status: CLOSED DUPLICATE of bug 68575
Product: Red Hat Raw Hide
Classification: Retired
Component: fileutils (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Aaron Brown
:
: 67936 68263 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-01 07:56 EDT by Petri Koistinen
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 20:38:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petri Koistinen 2002-07-01 07:56:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.5.24 i686; Nav)

Description of problem:
[root@dsl-hkigw4l83 Rawhide-RPMs]# rpm -Uvh fileutils-4.1.8-1.i386.rpm 
varoitus: fileutils-4.1.8-1.i386.rpm: Header V3 DSA signature: NOKEY, key ID
897da07a
Preparing...                ########################################### [100%]
varoitus: rpmtsRun: Header V3 DSA signature: NOKEY, key ID 897da07a
   1:fileutils              ########################################### [100%]
install-info: menu item `yes' already exists, for file `sh-utils'
virhe: execution of %post scriptlet from fileutils-4.1.8-1 failed, exit status 1
[root@dsl-hkigw4l83 Rawhide-RPMs]# rpm -q fileutils
fileutils-4.1-12
fileutils-4.1.8-1
[root@dsl-hkigw4l83 Rawhide-RPMs]# 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh fileutils-4.1.8-1.i386.rpm
2.
3.
	

Additional info:
Comment 1 Bernhard Rosenkraenzer 2002-07-01 08:04:01 EDT
You must update sh-utils (2.0.12-1) and textutils (2.0.21-5) at the same time.
Comment 2 Petri Koistinen 2002-07-05 10:02:34 EDT
It doesn't help.

[root@dsl-hkigw4l83 Rawhide-RPMs]# rpm -Uvh sh-utils-2.0.12-1.i386.rpm
textutils-2.0.21-5.i386.rpm 
Preparing...                ########################################### [100%]
   1:textutils              ########################################### [ 50%]
   2:sh-utils               ########################################### [100%]
[root@dsl-hkigw4l83 Rawhide-RPMs]# rpm -Uvh fileutils-4.1.9-1.i386.rpm 
Preparing...                ########################################### [100%]
   1:fileutils              ########################################### [100%]
install-info: menu item `yes' already exists, for file `sh-utils'
virhe: execution of %post scriptlet from fileutils-4.1.9-1 failed, exit status 1
[root@dsl-hkigw4l83 Rawhide-RPMs]# rpm -Uvh fileutils-4.1.9-1.i386.rpm
sh-utils-2.0.12-1.i386.rpm textutils-2.0.21-5.i386.rpm --force
Preparing...                ########################################### [100%]
   1:textutils              ########################################### [ 33%]
   2:fileutils              ########################################### [ 66%]
install-info: menu item `yes' already exists, for file `sh-utils'
virhe: execution of %post scriptlet from fileutils-4.1.9-1 failed, exit status 1
   3:sh-utils               ########################################### [100%]
[root@dsl-hkigw4l83 Rawhide-RPMs]#
Comment 3 Petri Koistinen 2002-07-05 12:07:12 EDT
I installed info-4.2-4 package which fixed the problem. /sbin/install-info
belongs to that package.
Comment 4 Bill Nottingham 2002-07-07 23:40:12 EDT
*** Bug 67936 has been marked as a duplicate of this bug. ***
Comment 5 Phil Knirsch 2002-07-09 04:20:57 EDT
*** Bug 68263 has been marked as a duplicate of this bug. ***
Comment 6 Petri Koistinen 2002-07-17 16:14:56 EDT
I guess problem is fixed.
Comment 7 Petri Koistinen 2002-08-05 11:30:24 EDT
Hmm, it's realy is not fixed in fileutils-4.1.9-4.i386.rpm yet.

   6:fileutils              ########################################### [  5%]
install-info: menu item `yes' already exists, for file `sh-utils'
virhe: execution of %post scriptlet from fileutils-4.1.9-4 failed, exit status 1
Comment 8 Bernhard Rosenkraenzer 2002-08-06 08:09:58 EDT
The "yes" entry for sh-utils can't exist with the current sh-utils package - 
it sh-utils.info doesn't exist anymore.
Comment 9 Preston Brown 2002-08-13 20:38:45 EDT
but it doesn't seem to be properly getting removed from the info-dir file.  I
ran into this problem too Bero.

Please test the upgrade case from a 7.3 box.
Comment 10 Preston Brown 2002-08-13 21:10:00 EDT

*** This bug has been marked as a duplicate of 68575 ***

Note You need to log in before you can comment on or make changes to this bug.