Bug 67782 - Freshen (rpm -Fhv ftp://...) has problems (with --oldpackage)
Freshen (rpm -Fhv ftp://...) has problems (with --oldpackage)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
: 91921 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-01 19:47 EDT by Dag Wieers
Modified: 2007-04-18 12:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 14:23:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dag Wieers 2002-07-01 19:48:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
I have a clean Red Hat 7.3 with additional openssh 3.3p1 packages (from
OpenSSH). While downgrading openssh (over the phone), there were problems when
using rpm -Fhv ftp://... in conjunction with --oldpackage, so I had to Update
with --oldpackage and --nodeps (so I could later remove the unnecessary packages)

After testing with a similar set-up, it seems to fail without any output. It is
debatable if --oldpackage should work with Freshen (-F).
But if it works with Update (-U) it might as well work with Freshen ;-)

Here's more output:

[root@anduin etc]# rpm -qa | grep openssh
openssh-3.3p1-1
openssh-server-3.3p1-1
openssh-clients-3.3p1-1
[root@anduin etc]# rpm -Fhv
ftp://updates.redhat.com/7.3/en/os/i386/openssh-*3.1p1-6*
Retrieving ftp://updates.redhat.com/7.3/en/os/i386/openssh-3.1p1-6.i386.rpm
Retrieving ftp://updates.redhat.com/7.3/en/os/i386/openssh-askpass-3.1p1-6.i386.rpm
Retrieving
ftp://updates.redhat.com/7.3/en/os/i386/openssh-askpass-gnome-3.1p1-6.i386.rpm
Retrieving ftp://updates.redhat.com/7.3/en/os/i386/openssh-clients-3.1p1-6.i386.rpm
Retrieving ftp://updates.redhat.com/7.3/en/os/i386/openssh-server-3.1p1-6.i386.rpm
[root@anduin etc]# rpm -qa | grep openssh
openssh-3.3p1-1
openssh-server-3.3p1-1
openssh-clients-3.3p1-1
[root@anduin etc]# rpm -Fhv
ftp://updates.redhat.com/7.3/en/os/i386/openssh-*3.1p1-6* --oldpackage
[root@anduin etc]# rpm -qa | grep openssh
openssh-3.3p1-1
openssh-server-3.3p1-1
openssh-clients-3.3p1-1
[root@anduin etc]# rpm -Uhv
ftp://updates.redhat.com/7.3/en/os/i386/openssh-*3.1p1-6*             
Retrieving ftp://updates.redhat.com/7.3/en/os/i386/openssh-3.1p1-6.i386.rpm
Retrieving ftp://updates.redhat.com/7.3/en/os/i386/openssh-askpass-3.1p1-6.i386.rpm
Retrieving
ftp://updates.redhat.com/7.3/en/os/i386/openssh-askpass-gnome-3.1p1-6.i386.rpm
Retrieving ftp://updates.redhat.com/7.3/en/os/i386/openssh-clients-3.1p1-6.i386.rpm
Retrieving ftp://updates.redhat.com/7.3/en/os/i386/openssh-server-3.1p1-6.i386.rpm
error: failed dependencies:
        libICE.so.6   is needed by openssh-askpass-3.1p1-6
        libSM.so.6   is needed by openssh-askpass-3.1p1-6
        libX11.so.6   is needed by openssh-askpass-3.1p1-6
        libXt.so.6   is needed by openssh-askpass-3.1p1-6
        libart_lgpl.so.2   is needed by openssh-askpass-gnome-3.1p1-6
        libaudiofile.so.0   is needed by openssh-askpass-gnome-3.1p1-6
        libesd.so.0   is needed by openssh-askpass-gnome-3.1p1-6
        libgdk-1.2.so.0   is needed by openssh-askpass-gnome-3.1p1-6
        libgdk_imlib.so.1   is needed by openssh-askpass-gnome-3.1p1-6
        libgnome.so.32   is needed by openssh-askpass-gnome-3.1p1-6
        libgnomesupport.so.0   is needed by openssh-askpass-gnome-3.1p1-6
        libgnomeui.so.32   is needed by openssh-askpass-gnome-3.1p1-6
        libgtk-1.2.so.0   is needed by openssh-askpass-gnome-3.1p1-6
        libICE.so.6   is needed by openssh-askpass-gnome-3.1p1-6
        libSM.so.6   is needed by openssh-askpass-gnome-3.1p1-6
        libX11.so.6   is needed by openssh-askpass-gnome-3.1p1-6
        libXext.so.6   is needed by openssh-askpass-gnome-3.1p1-6
        libXi.so.6   is needed by openssh-askpass-gnome-3.1p1-6
[root@anduin etc]# rpm -qa | grep openssh
openssh-3.3p1-1
openssh-server-3.3p1-1
openssh-clients-3.3p1-1
[root@anduin etc]# rpm -Uhv
ftp://updates.redhat.com/7.3/en/os/i386/openssh-*3.1p1-6* --oldpackage --nodeps
Retrieving ftp://updates.redhat.com/7.3/en/os/i386/openssh-3.1p1-6.i386.rpm
Retrieving ftp://updates.redhat.com/7.3/en/os/i386/openssh-askpass-3.1p1-6.i386.rpm
Retrieving
ftp://updates.redhat.com/7.3/en/os/i386/openssh-askpass-gnome-3.1p1-6.i386.rpm
Retrieving ftp://updates.redhat.com/7.3/en/os/i386/openssh-clients-3.1p1-6.i386.rpm
Retrieving ftp://updates.redhat.com/7.3/en/os/i386/openssh-server-3.1p1-6.i386.rpm
Preparing...                ########################################### [100%]
   1:openssh                ########################################### [ 20%]
   2:openssh-askpass        ########################################### [ 40%]
   3:openssh-askpass-gnome  ########################################### [ 60%]
   4:openssh-clients        warning: /etc/ssh/ssh_config created as
/etc/ssh/ssh_config.rpmnew
########################################### [ 80%]
   5:openssh-server         warning: /etc/ssh/sshd_config created as
/etc/ssh/sshd_config.rpmnew
########################################### [100%]
[root@anduin etc]# rpm -e openssh-askpass openssh-askpass-gnome

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See screendump
	

Actual Results:  It didn't say anything at all (not that it failed, not why it
failed)

Expected Results:  As expected on Unix, say when something fails (and maybe keep
quiet when everything works as comanded ;-))

As a sidenote, I don't know why it sometimes doesn't say (or simply doesn't)
download the packages. (See screendump also) I guess if it fails (for an unknown
reason) it leaves the packages behind, and sometimes not ?

Additional info:
Comment 1 Jeff Johnson 2003-06-25 13:39:56 EDT
*** Bug 91921 has been marked as a duplicate of this bug. ***
Comment 2 Paul Nasrat 2005-09-29 14:23:19 EDT
Freshen means verify package is installed and newer.  Trying to freshen an older
package does not make sense, freshen has worked as it's checked and determined
nothing to do which is not an error.

Note You need to log in before you can comment on or make changes to this bug.