This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 677908 - [abrt] gnome-screensaver-2.91.4-3.fc15: do_user_switch: Process /usr/libexec/gnome-screensaver-dialog was killed by signal 11 (SIGSEGV)
[abrt] gnome-screensaver-2.91.4-3.fc15: do_user_switch: Process /usr/libexec/...
Status: CLOSED DUPLICATE of bug 682608
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
abrt_hash:1239e18a7688a0f56b7414a66d2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-16 04:09 EST by Tim Lauridsen
Modified: 2012-03-21 11:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 11:51:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (31.33 KB, text/plain)
2011-02-16 04:09 EST, Tim Lauridsen
no flags Details

  None (edit)
Description Tim Lauridsen 2011-02-16 04:09:09 EST
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 32083 bytes
cmdline: /usr/libexec/gnome-screensaver-dialog --status-message= --enable-switch
component: gnome-screensaver
Attached file: coredump, 28860416 bytes
crash_function: do_user_switch
executable: /usr/libexec/gnome-screensaver-dialog
kernel: 2.6.38-0.rc4.git0.2.fc15.x86_64
package: gnome-screensaver-2.91.4-3.fc15
rating: 4
reason: Process /usr/libexec/gnome-screensaver-dialog was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Rawhide)
time: 1297847216
uid: 500

comment
-----
The I type my password in the screensaver lock password dialog i get 'incorect password'.
 I selected the 'Switch User' button and selected my already logged in user and type my password an get in but this crash occoured

How to reproduce
-----
1. boot into Fedora 15 Alpha TC2
2. Login
3. Click on username on top bar and select 'Lock Screen'
Comment 1 Tim Lauridsen 2011-02-16 04:09:12 EST
Created attachment 479055 [details]
File: backtrace
Comment 2 Tim Lauridsen 2011-02-16 04:37:01 EST
First i thought there it was because there was a '&' in my password so i tried
to change it.

I tried by clicking Username on the top bar and select 'My Account' and click on the password button to get the password change dialog. But I was not able to change it, because it did not except my old password.

I tried to use 'passwd' in a console and it would not accept my password either.

I tried using 'system-config-users' an was able to set a new password.

Now the lock screen password dialog was working again with my new password :)

I change the password to a new one with an '&' in it (Using the change password dialog in My account).

The lock screen password was still working.

I changed my password back to the original one and the lock screen password is still working.

So I cant reproduce it any more, it looks like my initial user creation with 'system-config-users' because kickstart is not working in F15 Alpha TC2 and I had to boot in init 3 and login with root, do a startx and launch 'system-config-users' and create my user rebooted and logon. Had broken the password for the user in some ways.

Feel free to close this report if like and it dont show any issues in the code.
Comment 3 Fedora Admin XMLRPC Client 2011-06-21 11:43:40 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 abrt-bot 2012-03-21 11:51:35 EDT
Backtrace analysis found this bug to be similar to bug #682608, closing as duplicate.

Bugs which were found to be similar to this bug: bug #682608, bug #684517, bug #691126, bug #697944, bug #698981

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 682608 ***

Note You need to log in before you can comment on or make changes to this bug.