Bug 67851 - gdm text unreadable in japanese locale
gdm text unreadable in japanese locale
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: fontconfig (Show other bugs)
beta3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Aaron Brown
:
: 68085 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-03 02:06 EDT by Jens Petersen
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-15 21:33:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2002-07-03 02:06:48 EDT
Description of Problem:
With the default system locale set to Japanese.  The text lines
immediately above and below the login/password entry box and
the gdm "panel" labels are unreadable.

Version-Release number of selected component (if applicable):
gdm-2.4.0.0-6

How Reproducible:
every time

Steps to Reproduce:
1. Set system locale to Japanese
2. Restart gdm

Actual Results:
All the text (except "Welcome to <hostname>" is so faint
as to be completely unreadable.

Expected Results:
The text should be clearly visible.
Comment 1 Havoc Pennington 2002-07-14 23:23:40 EDT
A font configuration issue one presumes.
Comment 2 Havoc Pennington 2002-07-14 23:26:04 EDT
*** Bug 68085 has been marked as a duplicate of this bug. ***
Comment 3 Owen Taylor 2002-07-15 15:15:19 EDT
Should be fixed in pango-1.0.99.020703-3.

 Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
- For FT2 backend, supply FT_LOAD_NO_BITMAP to avoid problems with
  fonts with embedded bitmaps (#67851)
Comment 4 Leon Ho 2002-07-15 21:33:54 EDT
Will it disable the embedded bitmap feature for GNOME2 all together?
Comment 5 Jens Petersen 2002-07-16 04:46:04 EDT
Confirmed fixed.  Thanks.
Comment 6 Owen Taylor 2002-07-16 11:59:39 EDT
No, this only disables it for rendering text via the GNOME canvas.

In most other places, bitmaps will be used as long as antialiasing
is off. (Offering the option of using embedded bitmaps where they
exist and antialiasing elsewhere may be something we want to do
eventually.)
Comment 7 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.