Bug 67854 - kdeinit fails with relocation error
kdeinit fails with relocation error
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kdelibs (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-03 03:15 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 16:03:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-03 03:15:39 EDT
Description of problem:
When starting X as KDE 3.0, the following error occurs: 
kdeinit: relocation error: /lib/libssl.so.2: undefined symbol: ENGINE_get_first
Tried nm /lib/libssl.so.2 | grep ENGINE_get_first:
 U ENGINE_get_first
Tried nm /lib/libcrypto.so.2 | grep ENGINE_get_first:
 0004d770 T ENGINE_get_first

Version-Release number of selected component (if applicable):
KDE 3.0
RedHat 7.3

How reproducible:
Always

Steps to Reproduce:
1. run startx with kde 3.0 as preferred window manager
	
Actual Results:  Error on console (see problem description).  
On KDE/X itself: get white message box error in KDE: "Cannot start kdeinit.  
Check your installation."  KDE then stops working correctly, especially kicker, 
which freezes after the first click.  

Additional info:
This is a result from an upgrade from 7.1 to 7.3.
Comment 1 Ngo Than 2002-10-10 08:24:33 EDT
strange, i cannot reproduce it on my local machine. Perhaps you still have old
openssl. Please try to get openssl-0.9.6b-18 from 7.3 or openssl-0.9.6b-28 from
7.3-errata.

Note You need to log in before you can comment on or make changes to this bug.