Bug 67861 - Error in Tomcat: Cannot set up certs for trusted CAs
Error in Tomcat: Cannot set up certs for trusted CAs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Web Application Framework
Classification: Retired
Component: installation (Show other bugs)
5.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-03 06:43 EDT by Bernd Huelsebusch
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-17 01:54:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tomcat Logfile (11.71 KB, text/plain)
2002-07-03 06:45 EDT, Bernd Huelsebusch
no flags Details

  None (edit)
Description Bernd Huelsebusch 2002-07-03 06:43:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
The systemlog of tomcat gives an error. CCM ist not available 

Version-Release number of selected component (if applicable):
- Windows2000
- Tomcat 3.2.3, SSL activated Certificate generated with Java-Keytools
- JDK1.3.1_01
- ACS Datamodel Oracle 8i installed (Connect to CCM with OracleThin Driver)

How reproducible:
Always

Steps to Reproduce:
Normal install of CCM 5.0 under windows2000/Tomcat 3.2.3/jdk1.3.1_01	

Actual Results:  Tomcat and CCM won't start

Expected Results:  Tomcat and CCM will start

Additional info:

Error Message in tomcat-logfile:

Starting tomcat. Check logs/tomcat.log for error messages 
Initialization using: /WEB-INF/resources/enterprise.init
2002-07-03 11:04:22,671 [ main] WARN  persistence.Initializer - Persistence 
initializer is starting
2002-07-03 11:04:22,765 [ main] WARN  persistence.Initializer - Found 101 files 
in the D:\Jakarta-Tomcat\webapps\acs-core\WEB-INF\pdl directory.
2002-07-03 11:04:26,000 [ main] WARN  caching.Initializer - Cache initializer 
starting
2002-07-03 11:04:26,000 [ main] WARN  caching.Initializer - CacheTable 
property: (key=SiteNode.age,value=600)
2002-07-03 11:04:26,000 [ main] WARN  caching.Initializer - CacheTable 
property: (key=SiteNode.size,value=100)
2002-07-03 11:04:26,000 [ main] WARN  globalization.Initializer - Globalization 
Initializer is starting.
2002-07-03 11:04:26,062 [ main] WARN  globalization.Initializer - Globalization 
Initializer has already been loaded.
2002-07-03 11:04:26,312 [ main] WARN  presentation.Initializer - Setting System 
property to use XALAN
2002-07-03 11:04:26,312 [ main] WARN  kernel.Initializer - Kernel Initializer 
is starting.
2002-07-03 11:04:26,609 [ main] WARN  security.Initializer - Security 
Initializer: starting
2002-07-03 11:04:26,625 [ main] WARN  security.Initializer - Security 
Initializer: mapping 10 pages
2002-07-03 11:04:26,625 [ main] WARN  security.Initializer - Security 
Initializer: JAAS lib found
2002-07-03 11:04:26,890 [ main] WARN  security.Crypto - Security Initializer: 
JCE lib found
2002-07-03 11:04:26,890 [ main] WARN  security.Crypto - Security Initializer: 
SunJCE found
2002-07-03 11:04:27,390 [ main] WARN  security.Initializer - Security 
Initializer: ERROR: 
java.lang.ExceptionInInitializerError: java.lang.SecurityException: Cannot set 
up certs for trusted CAs
	at javax.crypto.b.<clinit>([DashoPro-V1.2-120198])
	at javax.crypto.Mac.getInstance([DashoPro-V1.2-120198])
	at com.arsdigita.kernel.security.Crypto.initialize(Crypto.java:106)
	at com.arsdigita.kernel.security.Initializer.loadCryptography
(Initializer.java:382)
	at com.arsdigita.kernel.security.Initializer.startup
(Initializer.java:119)
	at com.arsdigita.initializer.Script.startup(Script.java:158)
	at com.arsdigita.initializer.Script.startup(Script.java:141)
	at com.arsdigita.dispatcher.InitializerServlet.init
(InitializerServlet.java:71)
	at javax.servlet.GenericServlet.init(GenericServlet.java:258)
	at org.apache.tomcat.core.ServletWrapper.doInit(ServletWrapper.java:317)
	at org.apache.tomcat.core.Handler.init(Handler.java:215)
	at org.apache.tomcat.core.ServletWrapper.init(ServletWrapper.java:296)
	at org.apache.tomcat.context.LoadOnStartupInterceptor.contextInit
(LoadOnStartupInterceptor.java:130)
	at org.apache.tomcat.core.ContextManager.initContext
(ContextManager.java:491)
	at org.apache.tomcat.core.ContextManager.init(ContextManager.java:453)
	at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:195)
	at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:235)
cannot load servlet name: init: java.lang.ExceptionInInitializerError
2002-07-03 12:00:38,843 [ad-23] ERROR dispatcher.BaseDispatcherServlet - error 
in BaseDispatcherServlet
java.lang.NullPointerException
	at com.arsdigita.kernel.security.UserContext.redirectToLoginPage
(UserContext.java:433)
	at com.arsdigita.kernel.security.UserContext.login(UserContext.java:348)
	at com.arsdigita.kernel.security.UserContext.<init>
(UserContext.java:130)
	at com.arsdigita.kernel.KernelDispatcherServlet.authenticateUser
(KernelDispatcherServlet.java:49)
	at com.arsdigita.dispatcher.BaseDispatcherServlet.startRequest
(BaseDispatcherServlet.java:376)
	at com.arsdigita.dispatcher.BaseDispatcherServlet.service
(BaseDispatcherServlet.java:235)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at org.apache.tomcat.core.ServletWrapper.doService
(ServletWrapper.java:405)
	at org.apache.tomcat.core.Handler.service(Handler.java:287)
	at org.apache.tomcat.core.ServletWrapper.service
(ServletWrapper.java:372)
	at org.apache.tomcat.core.ContextManager.internalService
(ContextManager.java:812)
	at org.apache.tomcat.core.ContextManager.service
(ContextManager.java:758)
	at 
org.apache.tomcat.service.http.HttpConnectionHandler.processConnection
(HttpConnectionHandler.java:213)
	at org.apache.tomcat.service.TcpWorkerThread.runIt
(PoolTcpEndpoint.java:416)
	at org.apache.tomcat.util.ThreadPool$ControlRunnable.run
(ThreadPool.java:501)
	at java.lang.Thread.run(Thread.java:484)
2002-07-03 12:00:38,906 [ad-23] ERROR dispatcher.BaseDispatcherServlet - error 
in BaseDispatcherServlet
java.lang.NullPointerException
	at com.arsdigita.kernel.security.UserContext.redirectToLoginPage
(UserContext.java:433)
	at com.arsdigita.kernel.security.UserContext.login(UserContext.java:348)
	at com.arsdigita.kernel.security.UserContext.<init>
(UserContext.java:130)
	at com.arsdigita.kernel.KernelDispatcherServlet.authenticateUser
(KernelDispatcherServlet.java:49)
	at com.arsdigita.dispatcher.BaseDispatcherServlet.startRequest
(BaseDispatcherServlet.java:376)
	at com.arsdigita.dispatcher.BaseDispatcherServlet.service
(BaseDispatcherServlet.java:235)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at org.apache.tomcat.core.ServletWrapper.doService
(ServletWrapper.java:405)
	at org.apache.tomcat.core.Handler.service(Handler.java:287)
	at org.apache.tomcat.core.ServletWrapper.service
(ServletWrapper.java:372)
	at org.apache.tomcat.core.ContextManager.handleError
(ContextManager.java:1183)
	at org.apache.tomcat.core.Handler.service(Handler.java:312)
	at org.apache.tomcat.core.ServletWrapper.service
(ServletWrapper.java:372)
	at org.apache.tomcat.core.ContextManager.internalService
(ContextManager.java:812)
	at org.apache.tomcat.core.ContextManager.service
(ContextManager.java:758)
	at 
org.apache.tomcat.service.http.HttpConnectionHandler.processConnection
(HttpConnectionHandler.java:213)
	at org.apache.tomcat.service.TcpWorkerThread.runIt
(PoolTcpEndpoint.java:416)
	at org.apache.tomcat.util.ThreadPool$ControlRunnable.run
(ThreadPool.java:501)
	at java.lang.Thread.run(Thread.java:484)
2002-07-03 12:00:49,312 [ad-13] WARN  login.SubsiteDispatcher - sending 
redirect to /register/ (base: register/)
2002-07-03 12:00:49,546 [ad-12] ERROR dispatcher.BaseDispatcherServlet - error 
in BaseDispatcherServlet
java.lang.NoClassDefFoundError
	at javax.crypto.Mac.getInstance([DashoPro-V1.2-120198])
	at com.arsdigita.kernel.security.Crypto.newMac(Crypto.java:126)
	at com.arsdigita.kernel.security.Credential.createValidator
(Credential.java:207)
	at com.arsdigita.kernel.security.Credential.create(Credential.java:130)
	at com.arsdigita.ui.login.UserRegistrationForm.init
(UserRegistrationForm.java:155)
	at com.arsdigita.bebop.FormSection.fireInit(FormSection.java:255)
	at com.arsdigita.bebop.FormSection$2.init(FormSection.java:270)
	at com.arsdigita.bebop.FormModel.fireFormInit(FormModel.java:369)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:325)
	at com.arsdigita.bebop.Form.process(Form.java:338)
	at com.arsdigita.bebop.Form$2.initialValue(Form.java:421)
	at com.arsdigita.bebop.RequestLocal.get(RequestLocal.java:122)
	at com.arsdigita.bebop.Form.getFormData(Form.java:355)
	at com.arsdigita.bebop.form.Widget.getParameterData(Widget.java:559)
	at com.arsdigita.bebop.form.Widget.generateWidget(Widget.java:471)
	at com.arsdigita.bebop.form.Widget.generateXML(Widget.java:429)
	at com.arsdigita.bebop.BoxPanel.generateXML(BoxPanel.java:116)
	at com.arsdigita.bebop.Form.generateXMLSansState(Form.java:184)
	at com.arsdigita.bebop.Form.generateXML(Form.java:162)
	at com.arsdigita.bebop.SimpleContainer.generateXML
(SimpleContainer.java:242)
	at com.arsdigita.bebop.BoxPanel.generateXML(BoxPanel.java:119)
	at com.arsdigita.bebop.Page.generateXML(Page.java:621)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:718)
	at com.arsdigita.bebop.PageDispatcher.dispatch(PageDispatcher.java:104)
	at com.arsdigita.dispatcher.MapDispatcher.dispatch
(MapDispatcher.java:141)
	at com.arsdigita.sitenode.SiteNodeDispatcher.siteNodeDispatch
(SiteNodeDispatcher.java:204)
	at com.arsdigita.sitenode.SiteNodeDispatcher.dispatch
(SiteNodeDispatcher.java:133)
	at com.arsdigita.dispatcher.BaseDispatcherServlet.service
(BaseDispatcherServlet.java:273)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at org.apache.tomcat.core.ServletWrapper.doService
(ServletWrapper.java:405)
	at org.apache.tomcat.core.Handler.service(Handler.java:287)
	at org.apache.tomcat.core.ServletWrapper.service
(ServletWrapper.java:372)
	at org.apache.tomcat.core.ContextManager.internalService
(ContextManager.java:812)
	at org.apache.tomcat.core.ContextManager.service
(ContextManager.java:758)
	at 
org.apache.tomcat.service.http.HttpConnectionHandler.processConnection
(HttpConnectionHandler.java:213)
	at org.apache.tomcat.service.TcpWorkerThread.runIt
(PoolTcpEndpoint.java:416)
	at org.apache.tomcat.util.ThreadPool$ControlRunnable.run
(ThreadPool.java:501)
	at java.lang.Thread.run(Thread.java:484)
2002-07-03 12:01:11,500 [ad-13] WARN  login.SubsiteDispatcher - sending 
redirect to /register/ (base: register/)
2002-07-03 12:01:11,593 [ad-12] ERROR dispatcher.BaseDispatcherServlet - error 
in BaseDispatcherServlet
java.lang.NoClassDefFoundError
	at javax.crypto.Mac.getInstance([DashoPro-V1.2-120198])
	at com.arsdigita.kernel.security.Crypto.newMac(Crypto.java:126)
	at com.arsdigita.kernel.security.Credential.createValidator
(Credential.java:207)
	at com.arsdigita.kernel.security.Credential.create(Credential.java:130)
	at com.arsdigita.ui.login.UserRegistrationForm.init
(UserRegistrationForm.java:155)
	at com.arsdigita.bebop.FormSection.fireInit(FormSection.java:255)
	at com.arsdigita.bebop.FormSection$2.init(FormSection.java:270)
	at com.arsdigita.bebop.FormModel.fireFormInit(FormModel.java:369)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:325)
	at com.arsdigita.bebop.Form.process(Form.java:338)
	at com.arsdigita.bebop.Form$2.initialValue(Form.java:421)
	at com.arsdigita.bebop.RequestLocal.get(RequestLocal.java:122)
	at com.arsdigita.bebop.Form.getFormData(Form.java:355)
	at com.arsdigita.bebop.form.Widget.getParameterData(Widget.java:559)
	at com.arsdigita.bebop.form.Widget.generateWidget(Widget.java:471)
	at com.arsdigita.bebop.form.Widget.generateXML(Widget.java:429)
	at com.arsdigita.bebop.BoxPanel.generateXML(BoxPanel.java:116)
	at com.arsdigita.bebop.Form.generateXMLSansState(Form.java:184)
	at com.arsdigita.bebop.Form.generateXML(Form.java:162)
	at com.arsdigita.bebop.SimpleContainer.generateXML
(SimpleContainer.java:242)
	at com.arsdigita.bebop.BoxPanel.generateXML(BoxPanel.java:119)
	at com.arsdigita.bebop.Page.generateXML(Page.java:621)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:718)
	at com.arsdigita.bebop.PageDispatcher.dispatch(PageDispatcher.java:104)
	at com.arsdigita.dispatcher.MapDispatcher.dispatch
(MapDispatcher.java:141)
	at com.arsdigita.sitenode.SiteNodeDispatcher.siteNodeDispatch
(SiteNodeDispatcher.java:204)
	at com.arsdigita.sitenode.SiteNodeDispatcher.dispatch
(SiteNodeDispatcher.java:133)
	at com.arsdigita.dispatcher.BaseDispatcherServlet.service
(BaseDispatcherServlet.java:273)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at org.apache.tomcat.core.ServletWrapper.doService
(ServletWrapper.java:405)
	at org.apache.tomcat.core.Handler.service(Handler.java:287)
	at org.apache.tomcat.core.ServletWrapper.service
(ServletWrapper.java:372)
	at org.apache.tomcat.core.ContextManager.internalService
(ContextManager.java:812)
	at org.apache.tomcat.core.ContextManager.service
(ContextManager.java:758)
	at 
org.apache.tomcat.service.http.HttpConnectionHandler.processConnection
(HttpConnectionHandler.java:213)
	at org.apache.tomcat.service.TcpWorkerThread.runIt
(PoolTcpEndpoint.java:416)
	at org.apache.tomcat.util.ThreadPool$ControlRunnable.run
(ThreadPool.java:501)
	at java.lang.Thread.run(Thread.java:484)
Comment 1 Bernd Huelsebusch 2002-07-03 06:45:12 EDT
Created attachment 63484 [details]
Tomcat Logfile
Comment 2 Richard Li 2002-07-16 10:34:41 EDT
This isn't a bug in CCM per se; it is due to the finicky nature of JAAS in JDK
1.3. We should have this fully resolved when we move to 1.4. To get around this
problem, you may want to search for the problems and see what other people have
done under Windows.
Comment 3 Bernd Huelsebusch 2002-07-17 01:54:13 EDT
This is for all who already had the same problem under Windows or whatever:
I've already fixed the bug by myself. In the package 'com.arsdigita.kernel'
I fixed the source 'ACSObjectCache' with the following patch at line 59:

private static String attributeName(Object key) {
      
      String strKey = "";
      if (key != null) {
        strKey = key.toString();       
      }       
      return ACSObject.BASE_DATA_OBJECT_TYPE + ":" + strKey;
      //return ACSObject.BASE_DATA_OBJECT_TYPE + ":" + key.toString();
}

When is it planned to provide a new version of CCM for download (CCM 5.0 is a 
little instable) ??

Sincerely yours, Bernd H|lsebusch
_________________________________________
 
Web Coordinator, eCommerce Representative
Johann A. Krause Maschinenfabrik GmbH
Richard-Taylor-Str. 89
28777 Bremen / Germany
 
Telefon :  +49 421 6888-2087
Telefax :  +49 421 6888-2098
email  :  bhuelsebusch@jakrause.com
Internet :  www.jakrause.com
Comment 4 Richard Li 2002-10-07 14:37:58 EDT
Thanks for the report. This should be fixed in 5.0.2.

Note You need to log in before you can comment on or make changes to this bug.