Bug 678783 - system-config-selinux TypeError: value is of the wrong type for this column
Summary: system-config-selinux TypeError: value is of the wrong type for this column
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 847746 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-19 15:35 UTC by Clyde E. Kunkel
Modified: 2012-08-15 08:15 UTC (History)
4 users (show)

Fixed In Version: policycoreutils-2.0.85-19.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-12 04:40:18 UTC


Attachments (Terms of Use)
semanage port -l (11.70 KB, text/plain)
2011-02-22 00:08 UTC, Clyde E. Kunkel
no flags Details
policy.24 file as requested (1.22 MB, application/x-gzip)
2011-02-23 02:21 UTC, Clyde E. Kunkel
no flags Details
Rawhide policy.24 as requested (1.21 MB, application/x-gzip)
2011-02-23 02:50 UTC, Clyde E. Kunkel
no flags Details

Description Clyde E. Kunkel 2011-02-19 15:35:52 UTC
Description of problem:
system-config-selinux fails with TypeError

Version-Release number of selected component (if applicable):
policycoreutils-2.0.85-12.fc15.x86_64

How reproducible:
each attempt from a gnome-terminal, no abrt output when icon clicked

Steps to Reproduce:
1. in gnome-terminal, system-config-selinux 
2.
3.
  
Actual results:
type error

Expected results:
management screen

Additional info:
gnome-terminal active in gnome-shell

$ sudo system-config-selinux
/usr/share/system-config-selinux/system-config-selinux.py:71: Warning: g_object_get_valist: object class `GnomeProgram' has no property named `default-icon'
  xml = gtk.glade.XML ("/usr/share/system-config-selinux/system-config-selinux.glade", domain=PROGNAME)
Traceback (most recent call last):
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 186, in <module>
    app = childWindow()
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 89, in __init__
    self.add_page(portsPage.portsPage(xml))
  File "/usr/share/system-config-selinux/portsPage.py", line 69, in __init__
    self.load()
  File "/usr/share/system-config-selinux/portsPage.py", line 131, in load
    self.store.set_value(iter, PORT_COL, k[0])
TypeError: value is of the wrong type for this column

Comment 1 Clyde E. Kunkel 2011-02-19 15:39:37 UTC
forgot to set severity...would say high

Comment 2 Miroslav Grepl 2011-02-21 12:45:24 UTC
Any chance you defined your own port mapping using "semanage port"?

Comment 3 Clyde E. Kunkel 2011-02-21 15:21:02 UTC
No. The only port indicated as accessible in system-config-firewall is 1024 UDP.

Comment 4 Daniel Walsh 2011-02-21 23:15:16 UTC
Could you attach the output of 

semanage port -l

Comment 5 Clyde E. Kunkel 2011-02-22 00:08:17 UTC
Created attachment 480023 [details]
semanage port -l

As requested....

Comment 6 Daniel Walsh 2011-02-22 14:38:37 UTC
Nothing there that I see.

I guess can you attach  a compressed version of your policy file.

/etc/selinux/targeted/policy/policy.24

Comment 7 Clyde E. Kunkel 2011-02-23 02:21:38 UTC
Created attachment 480312 [details]
policy.24 file as requested

Comment 8 Clyde E. Kunkel 2011-02-23 02:22:52 UTC
Oooops.....please disregard.  This is from F15AlphaRC1 not rawhide.  I will have to reboot and resupply.  Sorry for the confusion.

Comment 9 Clyde E. Kunkel 2011-02-23 02:50:58 UTC
Created attachment 480314 [details]
Rawhide policy.24 as requested

Comment 10 Miroslav Grepl 2011-02-23 09:51:20 UTC
I think if you just execute

# yum reinstall selinux-policy-targeted

it will work because of an issue with F15AlphaRC1.

Comment 11 Clyde E. Kunkel 2011-03-08 22:29:09 UTC
Did a fresh install of F15Alpha today (20110308) and yum updated from updates-testing and then yum install policycoreutils-gui.

Still getting:

sudo system-config-selinux
/usr/share/system-config-selinux/system-config-selinux.py:71: Warning: g_object_get_valist: object class `GnomeProgram' has no property named `default-icon'
  xml = gtk.glade.XML ("/usr/share/system-config-selinux/system-config-selinux.glade", domain=PROGNAME)
Traceback (most recent call last):
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 186, in <module>
    app = childWindow()
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 89, in __init__
    self.add_page(portsPage.portsPage(xml))
  File "/usr/share/system-config-selinux/portsPage.py", line 69, in __init__
    self.load()
  File "/usr/share/system-config-selinux/portsPage.py", line 131, in load
    self.store.set_value(iter, PORT_COL, k[0])
TypeError: value is of the wrong type for this column

Comment 12 Miroslav Grepl 2011-03-09 11:07:08 UTC
Could you make sure 

# yum reinstall selinux-policy-targeted

does not complain.

Comment 13 Clyde E. Kunkel 2011-03-09 18:35:24 UTC
(In reply to comment #12)
> Could you make sure 
> 
> # yum reinstall selinux-policy-targeted
> 
> does not complain.

The reinstall did not complain.  However:

sudo system-config-selinux is still failing with same traceback.

Comment 14 Daniel Walsh 2011-03-09 21:17:08 UTC
Fixed in policycoreutils-2.0.85-19.fc15

Comment 15 Fedora Update System 2011-03-09 22:02:32 UTC
policycoreutils-2.0.85-19.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/policycoreutils-2.0.85-19.fc15

Comment 16 Fedora Update System 2011-03-12 04:40:04 UTC
policycoreutils-2.0.85-19.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Milan Crha 2012-08-15 08:15:09 UTC
*** Bug 847746 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.