Bug 678799 - [abrt] setroubleshoot-server-3.0.25-1.fc14: browser.py:384:add_row:Error: NULL pointer
Summary: [abrt] setroubleshoot-server-3.0.25-1.fc14: browser.py:384:add_row:Error: NUL...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: 14
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:eb32c046
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-19 19:32 UTC by Clay
Modified: 2011-03-09 20:54 UTC (History)
3 users (show)

Fixed In Version: setroubleshoot-3.0.30-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-09 20:54:16 UTC


Attachments (Terms of Use)
File: backtrace (1.48 KB, text/plain)
2011-02-19 19:32 UTC, Clay
no flags Details

Description Clay 2011-02-19 19:32:19 UTC
abrt version: 1.1.14
architecture: i686
cmdline: /usr/bin/python -Es /usr/bin/sealert -s
component: setroubleshoot
executable: /usr/bin/sealert
kernel: 2.6.35.11-83.fc14.i686.PAE
package: setroubleshoot-server-3.0.25-1.fc14
reason: browser.py:384:add_row:Error: NULL pointer
release: Fedora release 14 (Laughlin)
time: 1298143844
uid: 500

backtrace
-----
browser.py:384:add_row:Error: NULL pointer

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/setroubleshoot/browser.py", line 626, in on_delete_button_clicked
    self.delete_current_alert()
  File "/usr/lib/python2.7/site-packages/setroubleshoot/browser.py", line 659, in delete_current_alert
    self.show_current_alert()
  File "/usr/lib/python2.7/site-packages/setroubleshoot/browser.py", line 716, in show_current_alert
    rb = self.add_row(p, sig, args)
  File "/usr/lib/python2.7/site-packages/setroubleshoot/browser.py", line 384, in add_row
    cr = pixmap.cairo_create()
Error: NULL pointer

Local variables in innermost frame:
pixmap: <gtk.gdk.Pixmap object at 0xbbaf6e4 (GdkPixmap at 0xa8fe330)>
if_text: u'If you believe that portreserve should be allowed search access on the ccrommett directory by default.'
rows: 1
plugin: <plugins.catchall.plugin object at 0xbbb3d0c>
self: <setroubleshoot.browser.BrowserApplet instance at 0xa859d0c>
args: ('0', 'dir')
cols: 4
then_text: u'You should report this as a bug.\nYou can generate a local policy module to allow this access.\nAllow this access for now by executing:\n# grep portrelease /var/log/audit/audit.log | audit2allow -M mypol\n# semodule -i mypol.pp'
sig: <setroubleshoot.signature.SEFaultSignatureInfo object at 0xbbb306c>
sev_image: <gtk.Image object at 0xbbaf914 (GtkImage at 0xa8e6a00)>
avc: [<setroubleshoot.audit_data.AuditRecord object at 0xbbb322c>, <setroubleshoot.audit_data.AuditRecord object at 0xbbb324c>]

How to reproduce
-----
1. Deleted a SELinux Alert
2.
3.

Comment 1 Clay 2011-02-19 19:32:21 UTC
Created attachment 479720 [details]
File: backtrace

Comment 2 Daniel Walsh 2011-02-21 23:16:49 UTC
Fixed in setroubleshoot-3.0.28-1.fc14

Comment 3 Fedora Update System 2011-02-21 23:19:21 UTC
setroubleshoot-3.0.28-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/setroubleshoot-3.0.28-1.fc14

Comment 4 Clay 2011-02-24 15:35:18 UTC
Package: setroubleshoot-server-3.0.25-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Reviewing SELinux alerts. Clicked on Previous.
2.
3.

Comment 5 Fedora Update System 2011-03-01 16:18:02 UTC
Package setroubleshoot-3.0.30-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing setroubleshoot-3.0.30-1.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/setroubleshoot-3.0.30-1.fc14
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-03-02 01:53:49 UTC
setroubleshoot-3.0.30-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update setroubleshoot'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/setroubleshoot-3.0.30-1.fc14

Comment 7 winhater 2011-03-05 11:19:44 UTC
Package: setroubleshoot-server-3.0.25-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Just start OS Linux
2.
3.

Comment 8 Daniel Walsh 2011-03-07 22:07:31 UTC
Test the package in updates testing and update the karma if it works for you.

Comment 9 Clay 2011-03-08 03:21:08 UTC
Have updated karma. Looks like patch works.

Thanks,
Clay

Comment 10 Fedora Update System 2011-03-09 20:53:45 UTC
setroubleshoot-3.0.30-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.