Bug 678812 - [abrt] minicom-2.5-1.fc14: mc_wclose: Process /usr/bin/minicom was killed by signal 11 (SIGSEGV)
Summary: [abrt] minicom-2.5-1.fc14: mc_wclose: Process /usr/bin/minicom was killed by ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: minicom
Version: 14
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Görig
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:830d958af6f024a4ceafa4ad448...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-19 21:32 UTC by Ed Marshall
Modified: 2011-03-09 20:52 UTC (History)
1 user (show)

Fixed In Version: minicom-2.5-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-09 20:52:39 UTC


Attachments (Terms of Use)
File: backtrace (10.68 KB, text/plain)
2011-02-19 21:32 UTC, Ed Marshall
no flags Details

Description Ed Marshall 2011-02-19 21:32:12 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: minicom -c on -D /dev/ttyUSB1 -o
component: minicom
crash_function: mc_wclose
executable: /usr/bin/minicom
kernel: 2.6.35.10-74.fc14.x86_64
package: minicom-2.5-1.fc14
rating: 4
reason: Process /usr/bin/minicom was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1298145199
uid: 500

How to reproduce
-----
1. Plug in USB serial device.
2. Start minicom connected to it.
3. Disconnect USB serial device.
4. Watch as minicom complains that device is no longer available in a polling loop w/delay. (Good!)
5. Reconnect USB serial device.
6. Minicom segfaults on next poll of device. (Bad!)

Comment 1 Ed Marshall 2011-02-19 21:32:15 UTC
Created attachment 479726 [details]
File: backtrace

Comment 2 Jan Görig 2011-02-24 11:37:25 UTC
Thank you for the bug report. Bug should be fixed in next update.

Comment 3 Fedora Update System 2011-02-24 11:39:11 UTC
minicom-2.5-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/minicom-2.5-3.fc14

Comment 4 Fedora Update System 2011-02-24 11:39:44 UTC
minicom-2.5-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/minicom-2.5-4.fc15

Comment 5 Ed Marshall 2011-02-24 13:26:44 UTC
That update looks like it does the trick, thank you! You just made my microcontroller testing significantly easier. :)

Comment 6 Jan Görig 2011-02-24 13:36:56 UTC
You are welcome :)

Comment 7 Fedora Update System 2011-02-24 20:52:21 UTC
minicom-2.5-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update minicom'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/minicom-2.5-3.fc14

Comment 8 Fedora Update System 2011-03-03 03:14:44 UTC
minicom-2.5-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-03-09 20:52:35 UTC
minicom-2.5-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.