Bug 678859 - Installing Bugzilla fails due to missing or unreadable directories
Summary: Installing Bugzilla fails due to missing or unreadable directories
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bugzilla
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Emmanuel Seyman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-20 13:00 UTC by Frédéric Buclin
Modified: 2011-03-16 19:54 UTC (History)
2 users (show)

Fixed In Version: bugzilla-3.6.4-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-13 04:41:25 UTC


Attachments (Terms of Use)

Description Frédéric Buclin 2011-02-20 13:00:16 UTC
When running checksetup.pl from the bugzilla 3.6.4 RPM, it cannot complete because /usr/share/bugzilla/lib/ doesn't exist, and an error is thrown. To fix the problem, simply include /usr/share/bugzilla/lib/README in the RPM as we do upstream with the official tarballs.

Then, once checksetup.pl completed, Bugzilla doesn't work from the web browser because it cannot read /etc/bugzilla/localconfig. Permissions for this file are correct, but the problem is that permissions set to /etc/bugzilla/ are root.root 750, meaning that 'apache' cannot access this directory at all.

Comment 1 Emmanuel Seyman 2011-02-27 12:44:10 UTC
I'll do this this week.

Comment 2 Fedora Update System 2011-03-08 09:33:58 UTC
bugzilla-3.6.4-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/bugzilla-3.6.4-2.fc14

Comment 3 Fedora Update System 2011-03-08 09:34:31 UTC
bugzilla-3.4.10-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/bugzilla-3.4.10-2.fc13

Comment 4 Fedora Update System 2011-03-08 09:34:58 UTC
bugzilla-3.6.4-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/bugzilla-3.6.4-5.fc15

Comment 5 Emmanuel Seyman 2011-03-08 09:46:53 UTC
(In reply to comment #0)
>
> When running checksetup.pl from the bugzilla 3.6.4 RPM, it cannot complete
> because /usr/share/bugzilla/lib/ doesn't exist, and an error is thrown. To fix
> the problem, simply include /usr/share/bugzilla/lib/README in the RPM as we do
> upstream with the official tarballs.

This is fixed.


> Then, once checksetup.pl completed, Bugzilla doesn't work from the web browser
> because it cannot read /etc/bugzilla/localconfig. Permissions for this file are
> correct, but the problem is that permissions set to /etc/bugzilla/ are
> root.root 750, meaning that 'apache' cannot access this directory at all.

I'm afraid I can't reproduce this. When I do a fresh install of the bugzilla rpm,
I get a /etc/bugzilla directory that is root:apache 750 .

Comment 6 Frédéric Buclin 2011-03-08 16:07:26 UTC
(In reply to comment #5)
> I'm afraid I can't reproduce this. When I do a fresh install of the bugzilla
> rpm,
> I get a /etc/bugzilla directory that is root:apache 750 .

I don't remember having edited permissions on it. Are you sure there is no cron job which checks permissions and corrects them if they are unexpected?

Comment 7 Fedora Update System 2011-03-13 04:41:10 UTC
bugzilla-3.6.4-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-03-16 19:51:40 UTC
bugzilla-3.4.10-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-03-16 19:53:56 UTC
bugzilla-3.6.4-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.