Bug 67896 - smb.conf's "hosts allow" should allow /yy for a netmask
smb.conf's "hosts allow" should allow /yy for a netmask
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-03 18:21 EDT by Octavio Alvarez
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-03 18:21:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Octavio Alvarez 2002-07-03 18:21:54 EDT
Description of Problem:
samba should recognize /yy parameters as network mask.

Version-Release number of selected component (if applicable):
samba-2.2.3a-6

How Reproducible:
Change a working smb.conf "hosts allow" directive to the xxx.xxx.xxx.xxx/yy 
format, and run smbclient -L BIGSERVER (locally, from BIGSERVER).

Works ok with: "hosts allow = 192.168.0.0/255.255.255.0 127.0.0.0/255.0.0.0"
... but not with: "hosts allow = 192.168.0.0/24 127.0.0.0/8"

I mark this as an enhancement because, although "man smb.conf" says that it 
recognizes ip/mask pairs, the example is written as "150.203.15.0/255.255.255.0"

Depending on the smb.conf configuration, you may get a "Not listening for 
calling name" or simply a "Connection failed".
Comment 1 Trond Eivind Glomsrxd 2002-07-03 18:35:26 EDT
I suggest you make that suggestion on a samba mailing list - one such address is
samba@lists.samba.org

Note You need to log in before you can comment on or make changes to this bug.