Bug 67900 - Can't compile e1000 driver into the kernel
Summary: Can't compile e1000 driver into the kernel
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-04 00:22 UTC by Samuel Flory
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-11 00:42:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Samuel Flory 2002-07-04 00:22:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
I get this error attempting to compile the e1000 driver into the kernel.

ld -m elf_i386  -r -o net.o 3c59x.o mii.o eepro100.o acenic.o e1000/e1000.o
Space.o setup.o net_init.o loopback.o auto_irq.o
ld: cannot open e1000/e1000.o: No such file or directory
make[3]: *** [net.o] Error 1
make[3]: Leaving directory `/stuff/src/linux-2.4.18-5.58/drivers/net'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/stuff/src/linux-2.4.18-5.58/drivers/net'
make[1]: *** [_subdir_net] Error 2
make[1]: Leaving directory `/stuff/src/linux-2.4.18-5.58/drivers'
make: *** [_dir_drivers] Error 2


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.make mrproper
2.confiure E1000 to compile directly into the kernel.
3.make dep clean bzImage
	

Additional info:

Comment 1 Samuel Flory 2002-07-05 17:59:55 UTC
Same issue with the e100 driver.

ld: cannot open e100/e100.o: No such file or directory
make[3]: *** [net.o] Error 1
make[3]: Leaving directory `/stuff/src/linux-2.4.18-5.58/drivers/net'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/stuff/src/linux-2.4.18-5.58/drivers/net'
make[1]: *** [_subdir_net] Error 2
make[1]: Leaving directory `/stuff/src/linux-2.4.18-5.58/drivers'
make: *** [_dir_drivers] Error 2


Are these 2 drivers intended to not be compiled into the kernel?  If so then you
shouldn't be able to select y.  Lack of a e1000 driver that can be built into
the kernel with make netbooting imposible with some newer boards.

Comment 2 Samuel Flory 2003-03-11 00:42:26 UTC
Works for me is newer kernels


Note You need to log in before you can comment on or make changes to this bug.