Bug 679034 - ntpstat doesn't include root delay in maximum error estimate
ntpstat doesn't include root delay in maximum error estimate
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ntp (Show other bugs)
5.6
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Miroslav Lichvar
Martin Cermak
:
Depends On:
Blocks: 830821
  Show dependency treegraph
 
Reported: 2011-02-21 06:05 EST by Miroslav Lichvar
Modified: 2012-06-11 09:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The "ntpstat" command printed an incorrect maximum error estimate. This occurred because the "time correct to within" value did not include the root delay. With this update, the value includes the root delay and the displayed "time correct to within" value is correct.
Story Points: ---
Clone Of:
: 830821 (view as bug list)
Environment:
Last Closed: 2011-07-21 02:44:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Lichvar 2011-02-21 06:05:48 EST
Description of problem:
The "time correct to within" value printed by ntpstat doesn't include root delay, only root dispersion, so the actual error might be larger than what is reported.

Version-Release number of selected component (if applicable):
ntp-4.2.2p1-9.el5_4.1

How reproducible:
Always

Steps to Reproduce:
1. ntpstat
2. ntpq -c 'rv 0'
3. compare rootdelay / 2 + rootdisp with the ntpstat's value
 
Actual results:
not equal

Expected results:
equal

Additional info:
http://pkgs.fedoraproject.org/gitweb/?p=ntp.git;a=blob_plain;f=ntpstat-0.2-maxerror.patch;hb=HEAD
Comment 5 Eva Kopalova 2011-06-30 08:45:44 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The "ntpstat" command printed an incorrect maximum error estimate. This occurred because the "time correct to within" value did not include the root delay. With this update, the value includes the root delay and the displayed "time correct to within" value is correct.
Comment 6 errata-xmlrpc 2011-07-21 02:44:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0980.html

Note You need to log in before you can comment on or make changes to this bug.