Bug 67914 - Finnish locale support missing
Finnish locale support missing
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
limbo
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-04 05:02 EDT by Markku Kolkka
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-15 14:14:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markku Kolkka 2002-07-04 05:02:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
I chose Finnish as the default language when installing, now most X programs
give warnings like:

# rhn_register

(rhn_register:27967): Gdk-WARNING **: locale not supported by Xlib

(rhn_register:27967): Gdk-WARNING **: can not set locale modifiers


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run any GTK-based program
2.
3.
	

Additional info:
Comment 1 Bill Nottingham 2002-07-07 23:51:13 EDT
What language is in /etc/sysconfig/i18n?
Comment 2 Mike A. Harris 2002-07-10 00:42:37 EDT
Please provide the requested information so this problem can be looked into.
Comment 3 Markku Kolkka 2002-07-10 04:27:12 EDT
LANG="fi_FI.UTF-8@euro"
SUPPORTED="en_US.UTF-8:en_US:en:fi_FI.UTF-8@euro:fi_FI:fi_FI.UTF-8:fi"
SYSFONT="LatArCyrHeb-16"
Comment 4 Markku Kolkka 2002-07-10 04:32:53 EDT
Using non-UTF-8 locale (fi_FI@euro) makes the system work a lot better.
Comment 5 Mike A. Harris 2002-08-06 00:22:29 EDT
If you change to:

export LANG=fi_FI.UTF-8

instead of the @euro... does it work ok?
Comment 6 Mike A. Harris 2002-08-06 00:35:11 EDT
Please respond ASAP.  If fi_FI.UTF-8 works ok, I can make an alias
to fix this.
Comment 7 Mike A. Harris 2002-08-06 01:25:21 EDT
Patch applied to XFree86 4.2.0-60.1 in rawhide to workaround this issue.
In addition to trying out the above and reporting back, please try the
new X build as well.

Awaiting confirmation fix works.
Comment 8 Markku Kolkka 2002-08-06 03:57:55 EDT
LANG=fi_FI.UTF-8 gives the same warnings on XFree86 4.2.0-56 (Limbo2):

$ up2date
Adding cert <X509Name object '/C=US/ST=North Carolina/L=Research Triangle
Park/O=Red Hat, Inc./OU=Red Hat Network Services/CN=RHNS Certificate
Authority/Email=rhns@redhat.com'>

(up2date:1159): Gdk-WARNING **: locale not supported by Xlib

(up2date:1159): Gdk-WARNING **: can not set locale modifiers

** (up2date:1159): WARNING **: could not find handler `onRegPackagePageBack'
Comment 9 Mike A. Harris 2002-08-07 23:44:47 EDT
How exactly was LANG=fi_FI.UTF-8 set?
Change it in /etc/sysconfig/i18n then reboot, and try it.
Does that work with the latest packages?
Comment 10 Markku Kolkka 2002-08-08 04:33:22 EDT
LANG is set in /etc/sysconfig/i18n, I'm running the latest version available
through up2date (XFree86-4.2.0-57.1) and the problem remains.
Comment 11 Mike A. Harris 2002-08-08 04:37:07 EDT
ARGH... The patch I added was in the src.rpm, but not actually getting
applied to the build.  I've added the necessary magic and am building
a new package.

4.2.0-60.4 and later should have the new aliases.  Please try that
version once it hits rawhide/up2date

Sorry for the goofup.
Comment 12 Mike A. Harris 2002-08-10 02:07:14 EDT
It's in rawhide now.
Comment 13 Mike A. Harris 2002-08-11 06:09:41 EDT
Somehow the package got changed to VFlib2...  changing back to XFree86
Comment 14 Markku Kolkka 2002-08-12 08:10:05 EDT
I upgraded to XFree86* version 4.2.0-60.4 from Rawhide, but emacs, up2date etc.
still give the same "locale not supported by Xlib" warnings.
Comment 15 Mike A. Harris 2002-08-15 13:22:52 EDT
Xlib does not support locale modifiers such as @euro, and wont likely
until some point in the future.  It's still unimplemented in CVS, and
doesn't appear on any published roadmaps.

So technically it isn't really a bug, it's an unimplemented feature.

Our installer, etc should not IMHO choose locale settings which are
unsupported.

I'm not sure what the proper solution is other than implementing
locale modifier support in Xlib, which is a bit over my head currently.


Comment 16 Markku Kolkka 2002-08-15 13:39:30 EDT
I'm currently _not_ using @euro locale modifier, the locale is fi_FI.UTF8.
Locale fi_FI@euro works without warnings, the problem is with _UTF8_ specifier,
not @euro.
Comment 17 Mike A. Harris 2002-08-15 14:06:21 EDT
My *point*, is that your bug report clearly shows:

# rhn_register

(rhn_register:27967): Gdk-WARNING **: locale not supported by Xlib

(rhn_register:27967): Gdk-WARNING **: can not set locale modifiers
                                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^


*THAT* is what is unsupported by XFree86, and wont be for this release.


Comment 18 Markku Kolkka 2002-08-15 14:14:18 EDT
I had another look at my /etc/sysconfig/i18n, because I had to install limbo2 by
upgrading from 7.3 (#68314) and the file is different from the one created by
Limbo1 installer. I commented out "CHARSET=8859-15" (left from 7.3?) and now the
warnings are gone.
Comment 19 Mike A. Harris 2002-08-15 15:11:24 EDT
Closing as RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.