Bug 67918 - gmp 4.1-2 breaks sawfish
gmp 4.1-2 breaks sawfish
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gmp (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
: 68156 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-04 06:29 EDT by Stefan Sorensen
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-07 23:49:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch from gmp home page. (585 bytes, patch)
2002-07-04 06:31 EDT, Stefan Sorensen
no flags Details | Diff

  None (edit)
Description Stefan Sorensen 2002-07-04 06:29:52 EDT
Random routines in gmp 4.1-2 are broken, hitting an assertion:
randraw.c:118: GNU MP assertion failed: ((mp_limb_t) 1 << m2exp) > c

Steps to Reproduce:
1. Run sawfish
2. Enable random window placement
3. Create a new window.
Comment 1 Stefan Sorensen 2002-07-04 06:31:08 EDT
Created attachment 63667 [details]
Patch from gmp home page.
Comment 2 jbowman 2002-07-07 17:28:08 EDT
*** Bug 68156 has been marked as a duplicate of this bug. ***
Comment 3 Trond Eivind Glomsrxd 2002-07-08 16:22:58 EDT
Fixed in gmp-4.1-4.

Note You need to log in before you can comment on or make changes to this bug.