Bug 67937 - Errors during update from rpm
Errors during update from rpm
Status: CLOSED DUPLICATE of bug 63290
Product: Red Hat Raw Hide
Classification: Retired
Component: cups (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-04 10:26 EDT by ellson
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-07 07:46:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ellson 2002-07-04 10:26:47 EDT
Description of Problem:
# rpm -Uvh --replacepkgs cups-1.1.15-3.i386.rpm
Preparing...                ########################################### [100%]
   1:cups                   ########################################### [100%]
the primary link for print must be /usr/bin/cancel


Version-Release number of selected component (if applicable):
cups-1.1.15-3.i386.rpm

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Bill Nottingham 2002-07-07 23:39:40 EDT
Exactly what version of cups did you have installed previously? What does
/var/lib/alternatives/print look like?
Comment 2 ellson 2002-07-08 00:01:55 EDT
Not sure what version of cups I had before.  Whatever the previous rawhide
version was.  However, I can reproduce the problem by using --replacepkgs

[root@beermat rawhide]# rpm -qa cups
cups-1.1.15-3
[root@beermat rawhide]# rpm -Uvh --replacepkgs cups-1.1.15-3.i386.rpm
Preparing...                ########################################### [100%]
   1:cups                   ########################################### [100%]
the primary link for print must be /usr/bin/cancel
[root@beermat rawhide]#

/var/lib/alternatives/print contains:

auto
/usr/bin/cancel
print-lp
/usr/bin/lp
print-lpq
/usr/bin/lpq
print-lpr
/usr/bin/lpr
print-lprm
/usr/bin/lprm
print-lpstat
/usr/bin/lpstat
print-lpc
/usr/sbin/lpc
print-cancelman
/usr/share/man/man1/cancel.1.gz

/usr/bin/cancel.cups
30
/usr/bin/lp.cups
/usr/bin/lpq.cups
/usr/bin/lpr.cups
/usr/bin/lprm.cups
/usr/bin/lpstat.cups
/usr/sbin/lpc.cups
/usr/share/man/man1/cancel.cups.1.gz

Comment 3 ellson 2002-07-16 16:59:38 EDT
If /var/lib/alternatives/print gets corrupted for some reason, its 
a real nightmare to find.  

Currently, /var/lib/alternatives/print is not owned by any package.
Why not make it owned by redhat-config-printer, and clear it out
anytime redhat-config-printer is reinstalled?
Comment 4 ellson 2002-07-16 17:02:03 EDT
Sorry, I meant to say  "...make it owned by redhat-switch-printer, and clear it
out anytime redhat-switch-printer is reinstalled?"
Comment 5 Bill Nottingham 2002-07-16 18:22:01 EDT
Then the system will fail everytime redhat-switch-printer is installed; this
isn't really practical.
Comment 6 ellson 2002-07-16 18:29:10 EDT
OK, but as it stands now you cannot fix a broken /var/lib/alternatives/print
by removing and reinstalling packages.

Perhaps cups and LPRng rpms should both rebuild the file if they find it
corrupt?  It wouldn't cause the system to fail any worse than before
any the system would then be reconfigurable with the gui tools.
Comment 7 Tim Waugh 2002-10-11 07:37:33 EDT

*** This bug has been marked as a duplicate of 63290 ***

Note You need to log in before you can comment on or make changes to this bug.