Bug 67972 - Text-mode installer drawing problems
Summary: Text-mode installer drawing problems
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 67902 68289 71588 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-04 23:22 UTC by Andreas Thienemann
Modified: 2007-04-18 16:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-15 18:32:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of installer showing problem with the border drawing (53.39 KB, image/jpeg)
2002-07-04 23:22 UTC, Andreas Thienemann
no flags Details
screenshot of installer showing problem with button drawing (53.18 KB, image/jpeg)
2002-07-04 23:24 UTC, Andreas Thienemann
no flags Details

Description Andreas Thienemann 2002-07-04 23:22:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
When running the text-mode installer, the "window borders" and "buttons" are not
correctly drawn. (See attached screenshots)
They do look somewhat "inverted".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. choose text at the boot prompt
2. lean back and enjoy
3.
	

Actual Results:  Strangely drawn userinterface

Expected Results:  correctly drawn userinterface

Additional info:

This bug happens only in the second part of the anaconda installer. The first
one, which is read from the bootimage displays correctly. The second part, which
is in my case (netinstall) loaded from the ftp server behaves strangely as
described above.

N.B. this bug occured while running in a VMware virtual machine. I haven't tried
yet to see if it happens also on different hardware with or without vmware.Gonna
try this.

Attached screenshots show the problem. Please note that in the second screenshot
"yes" is actually selected and not the "no" button as one might assume.

Comment 1 Andreas Thienemann 2002-07-04 23:23:00 UTC
Created attachment 63684 [details]
screenshot of installer showing problem with the border drawing

Comment 2 Andreas Thienemann 2002-07-04 23:24:54 UTC
Created attachment 63685 [details]
screenshot of installer showing problem with button drawing

Comment 3 Sam Varshavchik 2002-07-05 16:55:51 UTC
This bug is reproducible on an ordinary TUI install.  VMWare is not a factor.



Comment 4 Marius Andreiana 2002-07-08 10:25:54 UTC
Seems like it's a general ncurses problem. After install, I get strange colors
in text applications like 'ntsysv'.

Comment 5 Jay Turner 2002-07-08 17:46:32 UTC
*** Bug 68181 has been marked as a duplicate of this bug. ***

Comment 6 Michael Fulbright 2002-07-10 00:28:00 UTC
Known UTF-8 issues with slang/minislang.

Comment 7 Jay Turner 2002-07-10 05:49:57 UTC
*** Bug 68289 has been marked as a duplicate of this bug. ***

Comment 8 Jeremy Katz 2002-07-30 04:33:52 UTC
*** Bug 67902 has been marked as a duplicate of this bug. ***

Comment 9 Jeremy Katz 2002-07-30 04:34:53 UTC
Fixed by going back to minislang in anaconda

Comment 10 Jeff Needle 2002-08-15 16:16:12 UTC
*** Bug 71588 has been marked as a duplicate of this bug. ***

Comment 11 Jeff Needle 2002-08-15 18:32:51 UTC
*** Bug 71588 has been marked as a duplicate of this bug. ***

Comment 12 Mike McLean 2002-08-16 18:42:08 UTC
Haven't seen this in a while.
CLOSED->RAWHIDE


Note You need to log in before you can comment on or make changes to this bug.