This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 67976 - php -v reports undefined symbol errors
php -v reports undefined symbol errors
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: php (Show other bugs)
limbo
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
: 68054 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-04 20:42 EDT by Andrew Parker
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-14 15:10:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Parker 2002-07-04 20:42:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Running php -v yields errors:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.php -v
2.
3.
	

Actual Results:  Content-type: text/html

PHP Warning:  Unable to load dynamic library '/usr/lib/php4/imap.so' -
/usr/lib/php4/imap.so: undefined symbol: executor_globals_id in Unknown on line 0
PHP Warning:  Unable to load dynamic library '/usr/lib/php4/ldap.so' -
/usr/lib/php4/ldap.so: undefined symbol: executor_globals_id in Unknown on line 0
PHP Warning:  Unable to load dynamic library '/usr/lib/php4/pgsql.so' -
/usr/lib/php4/pgsql.so: undefined symbol: core_globals_id in Unknown on line 0
PHP Warning:  snmp: Unable to initialize module
Module compiled with module API=20020429, debug=0, thread-safety=1
PHP    compiled with module API=20020429, debug=0, thread-safety=0
These options need to match
 in Unknown on line 0
4.2.1


Expected Results:  Presumably:

4.2.1


Additional info:
Comment 1 Bill Nottingham 2002-07-08 01:04:07 EDT
*** Bug 68054 has been marked as a duplicate of this bug. ***
Comment 2 R P Herrold 2002-07-14 11:21:51 EDT
I have just added  68798 which is in a production release, and exhibits like
behaviour.  I built a clean test case to show the bug there.
Comment 3 R P Herrold 2002-07-14 15:10:22 EDT
See:  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=68798

The bug may well be an issue in the option parser not trimming leaded spaces,
contrary to the documentation at:

   http://www.php.net/manual/en/features.commandline.php
Comment 4 Phil Copeland 2002-08-05 14:13:23 EDT
[root@dhcp59-202 SPECS]# php -v
4.2.2
[root@dhcp59-202 SPECS]# 

Works for me with the current beta/rawhide

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.