Bug 67978 - i810 drm bug: After logout X Window, X crashes
i810 drm bug: After logout X Window, X crashes
Status: CLOSED ERRATA
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
limbo
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
: 66850 67112 67448 67601 67723 68050 68237 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-04 21:00 EDT by Ben Wu
Modified: 2014-01-21 17:48 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-28 14:23:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crashed X log (15.88 KB, text/plain)
2002-07-04 21:03 EDT, Ben Wu
no flags Details
ksymoops'ed crash when closing X (3.60 KB, text/plain)
2002-07-05 07:59 EDT, Michael Young
no flags Details

  None (edit)
Description Ben Wu 2002-07-04 21:00:53 EDT
Description of Problem:
Whenever I tried to logout from KDE or GNOME, the X crashes. Couldn't go back to
the login screen. Then it comes up with Xconfigurator program, I selected the
defaults settings for my monitor and video card, it also couldn't startup X for
testing. If I switch to virtual console, do a reboot and it can start X well.

Version-Release number of selected component (if applicable):
XFree86 Version 4.2.0 (Custom Build: 4.2.0-52) / X Window System
(protocol Version 11, revision 0, vendor release 6600)

How Reproducible:

Steps to Reproduce:
1. login to GNOME
2. Menu -> logout


Actual Results:
Crashed

Expected Results:
Back to GDM

Additional Information:
Comment 1 Ben Wu 2002-07-04 21:03:35 EDT
Created attachment 63686 [details]
Crashed X log
Comment 2 Michael Young 2002-07-05 04:43:50 EDT
I am probably seeing the same problem. I can start X once, but when I quit, I
get a blank text screen (on Alt-F7), Alt-F1 takes me back to the text console,
but X crashes with a similar error dump if I try to restart it. This was
happening before I upgraded to limbo as well, though I only noticed it recently,
so maybe it was introduced by one of the 7.3 updates.
Comment 3 Michael Young 2002-07-05 05:06:03 EDT
A quick check shows that the problem goes away if I boot from the 2.4.18-4
kernel update from 7.3, so I think the problem was introduced between 2.4.18-4
and 2.4.18-5, which roughly tallies with when I first noticed the problem on
valhalla.
Comment 4 Michael Young 2002-07-05 06:04:30 EDT
A quick check shows that the problem goes away if I boot from the 2.4.18-4
kernel update from 7.3, so I think the problem was introduced between 2.4.18-4
and 2.4.18-5, which roughly tallies with when I first noticed the problem on
valhalla.
Comment 5 Michael Young 2002-07-05 07:58:32 EDT
Sorry about the double comment (an accident with the 'back' button).

I have noticed there is a kernel oops in /var/log/messages corresponding to
stopping X, the ksymoops'ed version is attached.
Comment 6 Michael Young 2002-07-05 07:59:56 EDT
Created attachment 63784 [details]
ksymoops'ed crash when closing X
Comment 7 Michael Young 2002-07-05 12:47:07 EDT
I have been trawlling through bugzilla and I suspect bug 61172 , bug 67448 , bug
67601 and bug 67723 are all related to this one.
Comment 8 Michael Young 2002-07-05 12:48:03 EDT
Oops, I meant bug 67112 .
Comment 9 Bill Nottingham 2002-07-08 14:44:46 EDT
*** Bug 68237 has been marked as a duplicate of this bug. ***
Comment 10 Mattias Dahlberg 2002-07-09 06:56:39 EDT
I have the same problem. My system is based around the i815e chipset.

This is what the log says:

(EE) GARTInit: AGPIOC_INFO failed (Invalid argument)
(EE) I810(0): AGP GART support is not available. Make sure your kernel
       agpgart support or that the agpgart kernel module is loaded.
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
Comment 11 Mike A. Harris 2002-07-10 08:55:37 EDT
*** Bug 67448 has been marked as a duplicate of this bug. ***
Comment 12 Mike A. Harris 2002-07-10 08:56:24 EDT
*** Bug 67601 has been marked as a duplicate of this bug. ***
Comment 13 Mike A. Harris 2002-07-10 08:57:19 EDT
*** Bug 67112 has been marked as a duplicate of this bug. ***
Comment 14 Mike A. Harris 2002-07-10 08:58:45 EDT
*** Bug 68050 has been marked as a duplicate of this bug. ***
Comment 15 Mike A. Harris 2002-07-10 08:59:32 EDT
*** Bug 67723 has been marked as a duplicate of this bug. ***
Comment 16 Mike A. Harris 2002-07-10 09:05:14 EDT
*** Bug 66850 has been marked as a duplicate of this bug. ***
Comment 17 Mike A. Harris 2002-07-10 09:08:29 EDT
This problem is resolved internally and will be released in an upcoming
kernel erratum.  I've closed all dupe bugs caused by this issue as dupes
of this one so we can track further dupes on this bug ID.
Comment 18 Mike A. Harris 2002-07-10 09:09:08 EDT
Kernel with the fix is also avail for testing currently at:

http://people.redhat.com/arjanv/testkernels/
Comment 19 Michael Young 2002-07-10 09:23:29 EDT
The 2.4.18-5e kernel works for me - X can be restarted.
Comment 20 Mattias Dahlberg 2002-07-10 09:54:45 EDT
Will it be merged upstream?
Comment 21 Arjan van de Ven 2002-07-10 09:59:46 EDT
the patch was sent yesterday to the DRM XFree people and to Alan Cox for
upstream kernel inclusion
Comment 22 Elliot Peele 2002-07-26 09:54:55 EDT
Is there a chance that the bug fix for this will be pushed out within the next
month?
Comment 23 Arjan van de Ven 2002-07-26 09:56:42 EDT
we're working on finalizing the erratum,but want to do decent QA...
Comment 24 Warren Togami 2002-08-28 01:09:12 EDT
Has this been resolved in Rawhide?  It seems fixed in 2.4.18-6 (Valhalla).
Comment 25 Todd Booher 2002-08-28 01:23:50 EDT
Appears to be fixed in null (at least for me).
Comment 26 Elliot Peele 2002-08-28 14:23:06 EDT
wasn't this fixed with the 2.4.18-10 errata that went out last week
Comment 27 Arjan van de Ven 2002-08-28 15:22:45 EDT
yes it was 
I wonder why our errata thingy didn't automatically close this bug as fixed in
errata as it's supposed to do

Note You need to log in before you can comment on or make changes to this bug.