Bug 679876 - dns does not seem to persist into /etc/resolv.conf
dns does not seem to persist into /etc/resolv.conf
Status: CLOSED DUPLICATE of bug 675325
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ovirt-node (Show other bugs)
5.6
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-23 13:38 EST by bingdan
Modified: 2016-04-26 10:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-04 05:36:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description bingdan 2011-02-23 13:38:38 EST
Description of problem:
We setup up dns via first boot and /etc/resolv.conf does not get persisted.

Version-Release number of selected component (if applicable):
ovirt-node-1.0.54.2.el5
red hat enterprise virtualization hypervisor release 5.6 (8.1.el5)

How reproducible:
build a rhev hypervisor
/etc/resolv.conf will be empty

Steps to Reproduce:
1 boot with rhev hypervisor 
2 build machine
3 set dns
4 reboot machine
  
Actual results:
/etc/resolv.conf

Expected results:
/etc/resolv.conf should contain dns entiries

Additional info:
I went ahead remounted the FS rw and then persisted the /etc/resolv.conf.
Comment 1 Andrew Cathrow 2011-02-23 15:02:28 EST
(In reply to comment #0)
> Description of problem:
> We setup up dns via first boot and /etc/resolv.conf does not get persisted.
> 
> Version-Release number of selected component (if applicable):
> ovirt-node-1.0.54.2.el5
> red hat enterprise virtualization hypervisor release 5.6 (8.1.el5)
> 
> How reproducible:
> build a rhev hypervisor
> /etc/resolv.conf will be empty
> 
> Steps to Reproduce:
> 1 boot with rhev hypervisor 
> 2 build machine
> 3 set dns
> 4 reboot machine
> 
> Actual results:
> /etc/resolv.conf
> 
> Expected results:
> /etc/resolv.conf should contain dns entiries
> 
> Additional info:
> I went ahead remounted the FS rw and then persisted the /etc/resolv.conf.

The DNS should be set in the network settings menu on RHEV-H, either statically or via DHCP. How are your NICS configured?
Comment 2 Jeremy West 2011-02-24 09:56:06 EST
Dan,

I noticed that we don't have a support case created for this.  Please note that bugzilla is *not* a support tool.  The proper workflow is to work through Red Hat support for issues such as this prior to creating bugs. If needed, the support team assisting you will file bugs with our engineering team.

Thank you
Jeremy West
Red Hat Support Supervisor
Comment 3 bingdan 2011-02-24 10:13:50 EST
Hi Jeremy,Andrew ( I am a gps-er on site) we are creating a support case for this issue as well.

We set the network settings via menu on first boot / ovirt-conf...

After install and reboot the dns settings we set.. during firstboot were lost.

We will add the support case to the bug sorry for the confusion/incorrect process
Comment 4 bingdan 2011-02-24 10:21:12 EST
I have created a case #00427279.
Comment 5 Alan Pevec 2011-03-04 05:36:52 EST
(In reply to comment #3)
> After install and reboot the dns settings we set.. during firstboot were lost.

This looks like dhclient-script is clearing resolv.conf see bug 675325

*** This bug has been marked as a duplicate of bug 675325 ***

Note You need to log in before you can comment on or make changes to this bug.