Bug 680111 - [abrt] xfce4-volumed-0.1.11-2.fc15: xvd_calculate_avg_volume: Process /usr/bin/xfce4-volumed was killed by signal 8 (SIGFPE)
Summary: [abrt] xfce4-volumed-0.1.11-2.fc15: xvd_calculate_avg_volume: Process /usr/bi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-volumed
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5195d641e5421720d5a32482be9...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-24 11:50 UTC by Wolfgang Ulbrich
Modified: 2011-03-16 20:20 UTC (History)
1 user (show)

Fixed In Version: xfce4-volumed-0.1.12-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-11 06:07:44 UTC


Attachments (Terms of Use)
File: backtrace (22.55 KB, text/plain)
2011-02-24 11:50 UTC, Wolfgang Ulbrich
no flags Details
xfce4-mixer.xml (1.80 KB, text/xml)
2011-03-01 08:58 UTC, Wolfgang Ulbrich
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 727047 None None None Never

Description Wolfgang Ulbrich 2011-02-24 11:50:49 UTC
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 23093 bytes
cmdline: xfce4-volumed
comment: nothing else
component: xfce4-volumed
Attached file: coredump, 64020480 bytes
crash_function: xvd_calculate_avg_volume
executable: /usr/bin/xfce4-volumed
kernel: 2.6.38-0.rc5.git7.1.fc15.x86_64
package: xfce4-volumed-0.1.11-2.fc15
rating: 4
reason: Process /usr/bin/xfce4-volumed was killed by signal 8 (SIGFPE)
release: Fedora release 15 (Lovelock)
time: 1298548072
uid: 500

How to reproduce
-----
1.starting the xfce-desktop
2.
3.

Comment 1 Wolfgang Ulbrich 2011-02-24 11:50:52 UTC
Created attachment 480730 [details]
File: backtrace

Comment 2 Christoph Wickert 2011-02-28 18:12:11 UTC
Does the application crash every time you start Xfce or only sometimes?

Comment 3 Wolfgang Ulbrich 2011-02-28 23:00:36 UTC
Package: xfce4-volumed-0.1.11-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1.starting xfce
2.autostart xfce4-volumed
3.

Comment 4 Wolfgang Ulbrich 2011-02-28 23:17:46 UTC
Yes, everytime if i start the desktop.
So i've disable it in autostart

In a terminal

[rave@mother ~]$ xfce4-volumed 

** (xfce4-volumed:12126): WARNING **: Binding 'XF86AudioRaiseVolume' failed!

** (xfce4-volumed:12126): WARNING **: Binding 'XF86AudioLowerVolume' failed!

** (xfce4-volumed:12126): WARNING **: Binding 'XF86AudioMute' failed!
** (xfce4-volumed:12126): DEBUG: The card HDANVidiaAlsamixer was found and set as the current card.

** (xfce4-volumed:12126): DEBUG: There is no track label stored in xfconf

** (xfce4-volumed:12126): DEBUG: The wanted track could not be found, using the first one instead.

** (xfce4-volumed:12126): DEBUG: Current track has no volume channels, defaulting volume to 0.

Gleitkomma-Ausnahme (Speicherabzug geschrieben)

Comment 5 Christoph Wickert 2011-03-01 00:16:56 UTC
Thanks for the feedback. Please attach your ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-mixer.xml to this bug report.

Comment 6 Christoph Wickert 2011-03-01 00:54:59 UTC
And please tell me what version ox xfce4-mixer you are using.

Comment 7 Wolfgang Ulbrich 2011-03-01 08:58:56 UTC
Created attachment 481561 [details]
xfce4-mixer.xml

Comment 8 Wolfgang Ulbrich 2011-03-01 09:05:10 UTC
[rave@mother ~]$ rpm -qa xfce4-mixer
xfce4-mixer-4.8.0-1.fc15.x86_64

I'm a litlle bit confused because xfce4-mixer.xml says that HDANVidiaAlsamixer is my active audio-card! That'wrong because it's the hdmi-output from my graphic-card and i don't used it.

Comment 9 Christoph Wickert 2011-03-01 09:11:10 UTC
Which card are you using then? Does xfce4-volumed still crash if you select the correct card?

Comment 10 Christoph Wickert 2011-03-01 09:18:14 UTC
I have forwarded your bug to the developer of xfce4-volumed at
https://bugs.launchpad.net/fedora/+source/xfce4-volumed/+bug/727047

Comment 11 Wolfgang Ulbrich 2011-03-01 16:45:34 UTC
My default sound-card is a asus xonar XD.

But i 've found the problem. :)
After changing the  line 
<property name="active-card" type="string" value="HDANVidiaAlsamixer"/>
in
<property name="active-card" type="string" value="XonarDXAlsamixer"/>
in ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-mixer.xml, xfce4-volumed starts well.

[rave@mother ~]$ xfce4-volumed 

** (xfce4-volumed:13510): WARNING **: Binding 'XF86AudioRaiseVolume' failed!

** (xfce4-volumed:13510): WARNING **: Binding 'XF86AudioLowerVolume' failed!

** (xfce4-volumed:13510): WARNING **: Binding 'XF86AudioMute' failed!
** (xfce4-volumed:13510): DEBUG: The card XonarDXAlsamixer was found and set as the current card.

** (xfce4-volumed:13510): DEBUG: There is no track label stored in xfconf

** (xfce4-volumed:13510): DEBUG: The wanted track could not be found, using the first one instead.

** (xfce4-volumed:13510): DEBUG: Xfconf volume step: 5

I put xfce4-volumed back in autostart and after a new login i found it the taskmanager and i've no abrt-alarm.

I don't know what's 'xfce4-volumed:13510): DEBUG: There is no track label stored in xfconf' does mean, but xfce4-volumed is working.
But i don't know what xfce4-volumed really do, because i'am using the xfce-desktop the first time (running away from gnome).

Should i give this info's to https://bugs.launchpad.net/fedora/+source/xfce4-volumed/+bug/727047, or is this issue really a bug?

Thanks for helping.

Comment 12 Christoph Wickert 2011-03-01 17:18:56 UTC
(In reply to comment #11)

> But i don't know what xfce4-volumed really do, because i'am using the
> xfce-desktop the first time (running away from gnome).

xfce4-volumed is responsible for making the XF86Audio* keys work. They work fine without the volumed because we have bound them to amixer (as you can see in Preferences -> Keyboard -> Shortcuts), but the advantage of xfce4-volumed is that it displays notifications and reads the xfce4-mixer configuration.

> Should i give this info's to
> https://bugs.launchpad.net/fedora/+source/xfce4-volumed/+bug/727047, or is this
> issue really a bug?

Yes please, if you have a launchpad account, please report this, otherwise I'll forward your information. This is a bug, regardless of the configuration of the mixer he volumed should not crash.

> Thanks for helping.

You are welcome. We are trying to make a good Xfce 4.8 release for Fedora 15 in order to give all the gnome-shell refugees a new home. You can help us by reporting bugs, testing updates and giving feedback at https://admin.fedoraproject.org/updates or in the wiki at 
https://fedoraproject.org/wiki/Test_Day:2011-02-17_Xfce

If you like Xfce subscribe to the Xfce mailing list at
https://admin.fedoraproject.org/mailman/listinfo/xfce
or join the SIG at https://fedoraproject.org/wiki/SIGs/Xfce

Last but not least you can visit us at Chemnitzer Linuxtage, there will many Fedora contributors working at the Xfce booth.

Comment 13 Fedora Update System 2011-03-06 20:33:29 UTC
xfce4-volumed-0.1.12-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xfce4-volumed-0.1.12-1.fc14

Comment 14 Fedora Update System 2011-03-06 20:33:32 UTC
xfce4-volumed-0.1.12-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xfce4-volumed-0.1.12-1.fc15

Comment 15 Fedora Update System 2011-03-07 01:32:28 UTC
xfce4-volumed-0.1.12-1.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xfce4-volumed'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xfce4-volumed-0.1.12-1.fc15

Comment 16 Fedora Update System 2011-03-11 06:07:39 UTC
xfce4-volumed-0.1.12-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2011-03-15 21:48:47 UTC
xfce4-volumed-0.1.12-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Wolfgang Ulbrich 2011-03-16 20:20:39 UTC
I can confirm that the update fixed the issue.

THX


Note You need to log in before you can comment on or make changes to this bug.