Bug 68012 - redhat-config-xfree86 unable to start (probably related to ddcprobe)
redhat-config-xfree86 unable to start (probably related to ddcprobe)
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-05 04:47 EDT by Mattias Dahlberg
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-10 09:42:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mattias Dahlberg 2002-07-05 04:47:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461; .NET 
CLR 1.0.3705)

Description of problem:
When trying to start redhat-config-xfree86 I get the following error:

* ddcprobe returned bogus values:
ID: None
Name: None
HorizSync: None
VertSync: None

Traceback (most recent calls last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 1484, in ? 
dialog.update_ui()
  File "/usr/share/redhat-config-xfree86/xconf.py", line 1046, in update_ui if 
not res_radio.get_active():
AttributeError: 'NoneType' object has no attribute 'get_active'

The monitor is a Sony GDM-F400 19" connected to the computer using BNC. In 
other words, no DDC info available and xconf.py screams.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get a monitor using a BNC connection.
2. Start redhat-config-xfree86
	

Additional info:
Comment 1 Alexander Larsson 2002-07-05 07:06:57 EDT
Hmmm. What resolution do you run?
Comment 2 Miloš Komarčević 2002-07-05 07:38:10 EDT
Same problem here with the following setup:
Matrox Millenium card and a Panasonic TX-1713MAB monitor
I run at 1152x864@70
Comment 3 Alexander Larsson 2002-07-05 09:45:13 EDT
Can you try with redhat-config-xfree86 0.4.0 when it reaches rawhide (in a day
or so).
Comment 4 Mattias Dahlberg 2002-07-05 10:37:15 EDT
I run at 1280x960 (chosen during install).

Ok, I will try 0.4.0.
Comment 5 Mattias Dahlberg 2002-07-09 05:56:25 EDT
I went to rawhide today to look for 0.4.0, but I found 0.4.1 instead.

As with 0.3.4 it couldn't start. This is how the output looked this time:

Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 1128, in resolution_tog
gled
    self.state.set_resolution(res)
  File "/usr/share/redhat-config-xfree86/xconf.py", line 363, in set_resolution
    self.recalc_mode()
  File "/usr/share/redhat-config-xfree86/xconf.py", line 354, in recalc_mode
    availible = self.availible_resolutions()
  File "/usr/share/redhat-config-xfree86/xconf.py", line 481, in availible_resol
utions
    if rhpl.monitor.monitor_supports_mode(self.hsync, self.vsync, res):
  File "/usr/lib/python2.2/site-packages/rhpl/monitor.py", line 369, in monitor_
supports_mode
    hsync_list = list_from_string (monitor_hsync)
  File "/usr/lib/python2.2/site-packages/rhpl/monitor.py", line 361, in list_fro
m_string
    l.append( (string.atof(tmp[0]), string.atof(tmp[1])) )
  File "/usr/lib/python2.2/string.py", line 202, in atof
    return _float(s)
ValueError: invalid literal for float(): 30.0
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 1506, in ?
    dialog.update_ui()
  File "/usr/share/redhat-config-xfree86/xconf.py", line 1068, in update_ui
    availible = self.state.availible_resolutions()
  File "/usr/share/redhat-config-xfree86/xconf.py", line 481, in availible_resol
utions
    if rhpl.monitor.monitor_supports_mode(self.hsync, self.vsync, res):
  File "/usr/lib/python2.2/site-packages/rhpl/monitor.py", line 369, in monitor_
supports_mode
    hsync_list = list_from_string (monitor_hsync)
  File "/usr/lib/python2.2/site-packages/rhpl/monitor.py", line 361, in list_fro
m_string
    l.append( (string.atof(tmp[0]), string.atof(tmp[1])) )
  File "/usr/lib/python2.2/string.py", line 202, in atof
    return _float(s)
ValueError: invalid literal for float(): 30.0

Comment 6 Alexander Larsson 2002-07-09 08:55:46 EDT
Hmm? What locale are you using?
Comment 7 Alexander Larsson 2002-07-09 09:23:34 EDT
I'm fixing this in 0.4.3, but until then, can you try it with LANG="en_US"
Comment 8 Mattias Dahlberg 2002-07-10 03:42:18 EDT
Yes, with LANG=en_US it worked (I had LANG=sv_SE.UTF-8")

The program looks nice and changing resolutions works nicely. Maybe there could 
be an additional line in the "Display settings was changed" dialog saying 
something like "You need to log out for the changes to take effect"?

I had some minor problems when I tried to change video card (I tried because it 
said "Video card type: Unknown"). But I guess I should open a new Bugzilla Bug 
for that and not continue in this "unable to start" thread?
Comment 9 Alexander Larsson 2002-07-10 09:42:40 EDT
Oops...
There is already a "you need to log out" line, but i accidentally reversed an
if, so it only showed up when it didn't need to.

Anyway, the unknown graphics card means kudzu wasn't able to probe the card.
If you have further issues please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.