Bug 68017 - Cant get an IP address
Cant get an IP address
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: dhcpcd (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-05 07:52 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 12:54:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tarball of strace from network stop,tcpdump, dhclient and ifconfig eth0 up (8.77 KB, application/octet-stream)
2002-07-09 21:09 EDT, Need Real Name
no flags Details
Here's the text output of 'tcpdump -n -i eth0 -s 2000 -X port 67' when running dhclient (dhcpcd is not installed, dhclient is not listed as a component on bugzilla for limbo) (11.92 KB, text/plain)
2002-07-11 20:24 EDT, Need Real Name
no flags Details
scripted network/iptables down and tcpdump of dhclient on limbo 2, still does not work for me. (34.56 KB, text/plain)
2002-08-10 09:02 EDT, Need Real Name
no flags Details
tcpdump of RH7.3 dhcpcd run on limbo2. (8.00 KB, text/plain)
2002-08-10 09:40 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-07-05 07:52:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530

Description of problem:
Actually appears to be dhclient that does not receive any lease offers.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. As root, 'service network start'
2. This command fails (timeout?) on eth0's IP info
3. Power Off/On Cable modem, all lights on as normal, still didn't work

	

Actual Results:  Fails to get an IP address from my ISP.  Could just be
attbi.com, but it was working before I did the install.

Expected Results:  Should have gotten an IP address.

Additional info:
Comment 1 Thomas M Steenholdt 2002-07-06 03:44:13 EDT
How is you firewall configured... You need to be able to communicate on port
67-68 for DHCP configuration to work at all... Try "service iptables stop" and
do your test again... If this still doesn't work then the problem is not likely
to be the firewall configuration.
Comment 2 Need Real Name 2002-07-07 16:49:11 EDT
I should have mentioned that I did try without any firewall, and could not get
it to work. Trying just 'dhclient eth0'with the firewall down gave output
similiar to 'No Lease offers received'.
Comment 3 Olivier Baudron 2002-07-07 19:49:48 EDT
If your client is dhcpcd (the default one), then don't worry with the firewall:
dhcpcd builds its own IP packets on a raw socket, and so does not rely on the
network stack (where the kernel netfilter is). In other words, you cannot stop
dhcpcd to emit/listen on the wires, unless you plug the cable out.

For your problem, can you attach a trace of:
# /etc/init.d/network stop
# ifconfig eth0 up
# tcpdump -n -i eth0 -s 2000 -X port 67
# dhcpcd
Comment 4 Olivier Baudron 2002-07-08 06:21:02 EDT
Would it be possible that I'd be granted access to bug 67217 ?
Comment 5 Elliot Lee 2002-07-08 10:19:14 EDT
Nope. It's not even a real bug report, so there's nothing to look at anyways :)
Comment 6 Need Real Name 2002-07-09 21:09:57 EDT
Created attachment 64486 [details]
tarball of strace from network stop,tcpdump, dhclient and ifconfig eth0 up
Comment 7 Elliot Lee 2002-07-11 14:14:20 EDT
We need the output of tcpdump, not an strace of it running.
Comment 8 Need Real Name 2002-07-11 20:24:53 EDT
Created attachment 65024 [details]
Here's the text output of 'tcpdump -n -i eth0 -s 2000 -X port 67' when running dhclient (dhcpcd is not installed, dhclient is not listed as a component on bugzilla for limbo)
Comment 9 Elliot Lee 2002-08-08 13:07:55 EDT
Hmm, the tcpdump looks like you are receiving a reply from the server, but the dhclient 
process doesn't receive that reply, so I would bet on firewall problems.

Please give ideas on how I can reproduce the problem, or a patch.
Comment 10 Need Real Name 2002-08-10 09:02:13 EDT
Created attachment 69844 [details]
scripted network/iptables down and tcpdump of dhclient on limbo 2, still does not work for me.
Comment 11 Need Real Name 2002-08-10 09:40:35 EDT
Created attachment 69847 [details]
tcpdump of RH7.3 dhcpcd run on limbo2.
Comment 12 Elliot Lee 2002-08-26 06:51:35 EDT
Given that the problem seems specific to your system, and that there isn't any information I 
can use to reproduce it, and this bug report is turning into a support session, 
WORKSFORME. You need to track down your local Linux guru and/or avail yourself of all 
the wonderful free & pay support forums/services out there, because this is beyond what is 
probably a good idea to pursue via bugzilla.

Once you figure out how to cause the problem anywhere (especially on my system :) or 
have a patch, then please reopen and we can work on it again.

Note You need to log in before you can comment on or make changes to this bug.