Bug 68019 - Generated lilo.conf.anaconda file has a missing space or \n between hdb=ide-scsi and root= statement
Generated lilo.conf.anaconda file has a missing space or \n between hdb=ide-s...
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 68074 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-05 08:31 EDT by Chris Chabot
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-07 19:05:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Chabot 2002-07-05 08:31:42 EDT
Description of problem:
The generated lilo.conf.anaconda file has a missing space or \n between
hdb=ide-scsi and root= statement, thus writing: "hdb=ide-scsiroot=LABEL=/" thus
resulting in a boot failure (root not found)

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
Did a clean limbo install, using the default boot loader (grub). Then afterwards
tried to move lilo.conf.anaconda to lilo.conf, and running lilo.

This all worked fine except for the missing space / new line between the
hdb=ide-scsi and root=..
Comment 1 Jeremy Katz 2002-07-05 13:50:56 EDT
Fixed in CVS
Comment 2 Jeremy Katz 2002-07-06 13:25:31 EDT
*** Bug 68074 has been marked as a duplicate of this bug. ***
Comment 3 Jay Turner 2002-08-05 13:08:58 EDT
Looks like we are getting there, but still seeing some odd things on an SMP
system.  I end up with this line in /etc/lilo.conf.anaconda:

append="hda=ide-scsi root=LABEL=/ root=LABEL=/

Seems to me that we only need one "root=LABEL=/"
Comment 4 Jeremy Katz 2002-08-07 19:05:11 EDT
Picky, picky...  better fix in CVS
Comment 5 Jay Turner 2002-08-21 11:42:33 EDT
Fix confirmed with Milan-re0820.nightly tree.
Comment 6 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.