Bug 680232 - Difficulties to generate 32bit Qt application target on Fedora 14 (x86_64) linux platform
Difficulties to generate 32bit Qt application target on Fedora 14 (x86_64) li...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
14
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-24 13:34 EST by Alain-Pierre CHERTIER
Modified: 2011-02-25 05:13 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-24 13:41:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alain-Pierre CHERTIER 2011-02-24 13:34:57 EST
Description of problem:

Working under Qt Creator and trying to generate 32bit_x86 Qt application target on a 64bit_x86 linux platform (Fedora 14), the build process involved by/with Qt creator (qmake ?) has difficulties because having forcing "-spec linux-g++-32" mode in the build options under Qt Creator for the target application project :

Qt Creator / qmake generates & displays compilation error at build time, because requiring and not finding a "QtCore/qconfig-i386.h" include file So, on Fedora 14, I was not able till today to generate my app as 32bit target because the building process under Qt Creator is stopping at compiling step with error relative to not finding a required "QtCore/qconfig-i386.h" file.

So, what to do ? Where can be the incriminated missing "QtCore/qconfig-i386.h" include file ?
And, may be, this file is not the unique missing one...
I didn't find that "qconfig-i386.h" file at all, although I think my Qt Creator and Qt library & framework installations and setups are ok (standard installation and setup of relevant RPM/Fedora packages) on my 64bit linux platform (Fedora 14) that I'm keeping almost daily updated with Fedora online update system tool.

Very annonying.

Kind regards and many thanks in advance for any help/suggestion/solution.

Alain-Pierre Chertier 



Version-Release number of selected component (if applicable):

x86_64 Fedora 14 -> Qt 4.7.x, Qt Creator 2.0.94 based on Qt 4.7.0 (64bit)

rpm -qa | grep qt
qt-x11-4.7.1-7.fc14.x86_64
qt-4.7.1-7.fc14.x86_64
qt-demos-4.7.1-7.fc14.x86_64
dbusmenu-qt-0.6.3-1.fc14.1.x86_64
qt3-3.3.8b-30.fc14.x86_64
qtparted-0.4.5-25.fc14.x86_64
qt-examples-4.7.1-7.fc14.x86_64
qt-devel-4.7.1-7.fc14.x86_64
qt-creator-2.1.0-4.rc1.fc14.x86_64
qt-webkit-4.7.1-7.fc14.x86_64
polkit-qt-0.96.1-4.fc14.x86_64
qt-sqlite-4.7.1-7.fc14.x86_64

=> why clicking on Qt Creator "about" menu is reporting "Qt Creator 2.0.94 based on Qt 4.7.0 (64bit)" while "qt-creator-2.1.0-4.rc1.fc14.x86_64" package seems to be installed ?

rpm -qa | grep glibc

glibc-headers-2.13-1.x86_64
glibc-devel-2.13-1.i686
glibc-2.13-1.x86_64
glibc-common-2.13-1.x86_64
glibc-devel-2.13-1.x86_64
glibc-2.13-1.i686



How reproducible:

The simple "weathertrayicon" example application proposed in the "Advanced Qt Programming" book from M.Summerfield can be used to experiment (that is the example application I cannot build as 32bit mode on my x86_64 Fedora 14 platform if forcing the "-spec linux-g++-32" building mode).


Steps to Reproduce:
1. forcing the "-spec linux-g++-32" building mode for project being developped inside Qt Creator
2.
3.
  
Actual results:

Exécution des étapes de compilation pour le projet weathertrayicon...
Commence : "/usr/bin/make" clean -w
make : on entre dans le répertoire « /home/aoip/projets/divers/aqp/weathertrayicon-build-desktop »
rm -f moc_weathertrayicon.cpp
rm -f qrc_weathertrayicon.cpp
rm -f kuhn_munkres.o md5.o alt_key.o option_parser.o weathertrayicon.o main.o moc_weathertrayicon.o qrc_weathertrayicon.o
rm -f *~ core *.core
make: on quitte le répertoire « /home/aoip/projets/divers/aqp/weathertrayicon-build-desktop »
Le processus "/usr/bin/make" s'est terminé normalement.
Configuration inchangée, étape QMake sautée.
Commence : "/usr/bin/make" -w
make : on entre dans le répertoire « /home/aoip/projets/divers/aqp/weathertrayicon-build-desktop »
g++ -c -m32 -pipe -g -Wall -W -D_REENTRANT -DNO_REGEX -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I/usr/lib64/qt4/mkspecs/linux-g++-32 -I../weathertrayicon -I/usr/include/QtCore -I/usr/include/QtNetwork -I/usr/include/QtGui -I/usr/include/QtXml -I/usr/include -I../aqp -I../option_parser -I. -I../weathertrayicon -I. -o kuhn_munkres.o ../aqp/kuhn_munkres.cpp
In file included from /usr/include/QtCore/qglobal.h:62:0,
                 from /usr/include/QtCore/qscopedpointer.h:45,
                 from /usr/include/QtCore/qdatastream.h:45,
                 from /usr/include/QtCore/qpair.h:45,
                 from /usr/include/QtCore/QPair:1,
                 from ../aqp/kuhn_munkres.hpp:25,
                 from ../aqp/kuhn_munkres.cpp:17:
/usr/include/QtCore/qconfig.h:10:34: erreur fatale: QtCore/qconfig-i386.h : Aucun fichier ou dossier de ce type
compilation terminée.
make: *** [kuhn_munkres.o] Erreur 1
make: on quitte le répertoire « /home/aoip/projets/divers/aqp/weathertrayicon-build-desktop »
Le processus "/usr/bin/make" s'est terminé avec le code 2.
Erreur à la compilation du projet weathertrayicon (cible : Bureau)
Lors de l'exécution de l'étape 'Make'

Expected results:

no build warning, no build error ?


Additional info:

To not surcharge the description here, I can also propose to give links to 2 discussions I've had also about such problems on Ubuntu 10.10 platform (not exactly same problems, but in the same goal to build a 32bit x86 Qt app target) on separate forums and Qt bug reporting system, all fine details can be found in these discussions :

    * about Qt Creator / qmake for building and running 32bit Qt app on x86_64 Ubuntu 10.10 and/or Fedora 14

=> http://developer.qt.nokia.com/forums/viewthread/3719/

=> http://bugreports.qt.nokia.com/browse/QTCREATORBUG-3794?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

=> http://bugreports.qt.nokia.com/browse/QTBUG-17747?page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#issue-tabs

    * about 32bit Qt app build error on x86_64 Fedora 14 with make/qmake under Qt Creator (and mix of problems on Ubuntu 10.10 & Fedora 14)

=> http://www.cyberciti.biz/faq/x86_64-linux-error-gnustub-32h-missing-error-and-solution/#comment-55956

Did/Can someone have/reproduce same problems and even compare with other x86_64 linux distribs about that ?
Comment 1 Kevin Kofler 2011-02-24 13:41:26 EST
su -c "yum install qt-devel.i686"
Comment 2 Alain-Pierre CHERTIER 2011-02-25 05:13:29 EST
Ok, installing the qt-devel.i686 did the job.
All is working fine now, many many thanks !
:-)
Alain-Pierre

Note You need to log in before you can comment on or make changes to this bug.