Bug 680292 - Molecular mechanics not supported
Summary: Molecular mechanics not supported
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openbabel
Version: rawhide
Hardware: i686
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-24 22:51 UTC by lg
Modified: 2011-03-27 03:10 UTC (History)
4 users (show)

Fixed In Version: openbabel-2.3.0-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-27 03:10:54 UTC


Attachments (Terms of Use)
quick fix for plugin directory location (512 bytes, patch)
2011-03-19 19:53 UTC, lg
no flags Details | Diff
show forcefields list in obenergy output (580 bytes, patch)
2011-03-19 19:57 UTC, lg
no flags Details | Diff
fix for forcefield extension (3.09 KB, patch)
2011-03-20 18:34 UTC, lg
no flags Details | Diff
fix autooptimization tool (698 bytes, patch)
2011-03-20 18:42 UTC, lg
no flags Details | Diff

Description lg 2011-02-24 22:51:44 UTC
Description of problem:

Molecular mechanics is not available and autooptimization tool doesn't work. The start button is greyed out

Version-Release number of selected component (if applicable):

avogadro-1.0.1-13.fc15.i686
openbabel-libs-2.3.0-2.fc15.i686

How reproducible:
Always

Steps to Reproduce:
1. open avogadro
2. draw any molecule
3. make sure that Tool settings display  is turned on
4. click autooptimization tool on toolbar (leter E with down arrow)

Actual results:
Force field cannot be selected and start button is greyed out

Expected results:
The force field should contain at least 2 entries (UFF and MMF94). The start button should be active

Additional info:
May actually be openbabel bug since obenergy produces strange output

$ obenergy
Usage: obenergy [options] <filename>

options:      description:

  -v          verbose: print out indivual energy interactions

  -h          add hydrogens before calculating energy

  -ff ffid    select a forcefield

              available forcefields:

forcefields is not a recognized plugin type. Those with instances of sub-types loaded are:

Comment 1 Kevin Kofler 2011-02-24 23:19:09 UTC
Yeah, I'd blame obenergy there.

Comment 2 lg 2011-02-26 19:55:06 UTC
$ strace obenergy -L
[skipped]
open("/usr//usr/lib/openbabel/2.3.0", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
write(2, "obenergy", 8)                 = 8
write(2, ": cannot read input format!", 27) = 27
write(2, "\n", 1)                       = 1
exit_group(-1)                          = ?

Note /usr//usr/

Comment 3 lg 2011-03-19 19:53:32 UTC
Created attachment 486409 [details]
quick fix for plugin directory location

%cmake macros in openbabel.spec sets -DCMAKE_INSTALL_LIBDIR:PATH=/usr/lib which breaks openbabel build system.

Comment 4 lg 2011-03-19 19:57:13 UTC
Created attachment 486410 [details]
show forcefields list in obenergy output

The patch fixes "forcefields is not a recognized plugin type. Those with instances of sub-types loaded are:" message when obenergy is called without parameters

Comment 5 lg 2011-03-19 19:59:50 UTC
These patches don't fix the problem described in https://bugzilla.redhat.com/show_bug.cgi?id=680292#c0 but without them all openbabel binaries will do not work

Comment 6 lg 2011-03-20 18:34:15 UTC
Created attachment 486493 [details]
fix for forcefield extension

This was fixed in avogadro commit 9653f3769f985926c1021f3480df7a253f4ff71d. The patch is simply diff between avogadro 1.0.1 and current git version. It also includes commit 50acbbeba91236a1387a10011438a32ce73ce69e

Comment 7 lg 2011-03-20 18:42:27 UTC
Created attachment 486495 [details]
fix autooptimization tool

The patch is essentially the same as for forcefield extension. With these patches both openbabel binaries (babel, obenergy, obminimize) and avogadro work as expected. Tested on fedora 14

Comment 8 Kevin Kofler 2011-03-21 00:50:19 UTC
Oh fun, so we have 2 OpenBabel bugs and 2 Avogadro bugs. I'm going to apply the fixes for all.

Comment 9 Kevin Kofler 2011-03-21 07:32:10 UTC
I cannot reproduce any of these issues on F14 with openbabel-2.2.3-4.fc14, so I'm going to assume that those are all regressions caused by OpenBabel 2.3.0, and thus need fixing only in F15 and Rawhide.

Comment 10 Kevin Kofler 2011-03-21 07:33:52 UTC
BTW, I wonder if other OpenBabel users also need fixing for this silent incompatible change in 2.3.0.

Comment 11 Fedora Update System 2011-03-22 22:43:26 UTC
openbabel-2.3.0-3.fc15,avogadro-1.0.1-14.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/openbabel-2.3.0-3.fc15,avogadro-1.0.1-14.fc15

Comment 12 Fedora Update System 2011-03-27 03:10:49 UTC
openbabel-2.3.0-3.fc15, avogadro-1.0.1-14.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.