Bug 680297 - [abrt] remmina-0.7.5-3.fc14: remmina_connection_holder_toolbar_autofit_restore: Process /usr/bin/remmina was killed by signal 11 (SIGSEGV)
Summary: [abrt] remmina-0.7.5-3.fc14: remmina_connection_holder_toolbar_autofit_restor...
Keywords:
Status: CLOSED DUPLICATE of bug 620106
Alias: None
Product: Fedora
Classification: Fedora
Component: remmina
Version: 14
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e9a836fbe6ad527b97343351ced...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-24 23:31 UTC by Alan Ernhart
Modified: 2011-02-25 20:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-25 08:43:22 UTC


Attachments (Terms of Use)
File: backtrace (20.59 KB, text/plain)
2011-02-24 23:32 UTC, Alan Ernhart
no flags Details

Description Alan Ernhart 2011-02-24 23:31:58 UTC
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 21080 bytes
cmdline: remmina
component: remmina
Attached file: coredump, 49127424 bytes
crash_function: remmina_connection_holder_toolbar_autofit_restore
executable: /usr/bin/remmina
kernel: 2.6.36.1-10.fc15.x86_64
package: remmina-0.7.5-3.fc14
rating: 4
reason: Process /usr/bin/remmina was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1298588754
uid: 500

How to reproduce
-----
1. I had two RDP sessions connected in Remina while using the Remmina session editor.
2. I rebooted one of the remote systems, then Copied one session definition into another in remmina session editor.
3. When I expected the remote Windows system to have rebooted, I connected to it from the session editor with the Windows userID and password stored in Remmina.
The connection got to the login screen of Windows. This was a Windows account that I'd created before the reboot and for which I'd forgotten to create a password. The effect was that Windows rejected the connection with some kind of dialog message. I only got a glimpse of it before Remmina crashed.
The remote system was Windows 7 Pro.

Comment 1 Alan Ernhart 2011-02-24 23:32:00 UTC
Created attachment 480884 [details]
File: backtrace

Comment 2 Alan Ernhart 2011-02-24 23:34:56 UTC
Yes, I'm running a F15 kernel in F14 (due to Lenovo W500 suspend issues with the F14 kernel). I'm not sure if this contributed to the crash, but I have used Remmina on this system without incident.

I may try to repro, and certainly would if you asked. Thanks.

Comment 3 Christoph Wickert 2011-02-25 08:43:22 UTC
Thanks for submitting this bug report. Unfortunately remmina 0.7.x is very broken but upstream doesn't want to be bothered with bugs against the old packages because 0.8.0 was a complete rewrite. I cannot bring it to F13 or F13 because of the new updates policy.

I will host backported packages for F13 and F14 at
http://repos.fedorapeople.org/repos/cwickert/remmina/

The repo is still empty but I hope I find the time on the weekend.

*** This bug has been marked as a duplicate of bug 620106 ***

Comment 4 Christoph Wickert 2011-02-25 20:32:07 UTC
Updated remmina packages are now available from 
http://repos.fedorapeople.org/repos/cwickert/remmina/
Please keep in mind that the plugins are no longer part of the main application and you have to install the plugins you want manually.


Note You need to log in before you can comment on or make changes to this bug.