Bug 68054 - PHP modules will not load
PHP modules will not load
Status: CLOSED DUPLICATE of bug 67976
Product: Red Hat Public Beta
Classification: Retired
Component: php (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-05 17:36 EDT by Ray Parish
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-05 17:36:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Parish 2002-07-05 17:36:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
PHP modules (imap, ldap, mysql, pgsql etc) will not load.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Limbo
2.Create sample php script
<? mysql_connect('localhost','root',''); ?>
3./usr/bin/php /path/to/phpscript.php
	

Actual Results:  [root@pulse root]# /usr/bin/php /var/www/html/index.php
Content-type: text/html

PHP Warning:  Unable to load dynamic library '/usr/lib/php4/imap.so' -
/usr/lib/php4/imap.so: undefined symbol: executor_globals_id in Unknown on line 0
PHP Warning:  Unable to load dynamic library '/usr/lib/php4/ldap.so' -
/usr/lib/php4/ldap.so: undefined symbol: executor_globals_id in Unknown on line 0
PHP Warning:  Unable to load dynamic library '/usr/lib/php4/php_mysql.so' -
/usr/lib/php4/php_mysql.so: cannot open shared object file: No such file or
directory in Unknown on line 0
X-Powered-By: PHP/4.2.1
Content-type: text/html

<br />
<b>Fatal error</b>:  Call to undefined function:  mysql_connect() in
<b>/var/www/html/index.php</b> on line <b>1</b><br />

Expected Results:  no error on loading dynamic modules.

Additional info:
Comment 1 Bill Nottingham 2002-07-08 01:04:11 EDT

*** This bug has been marked as a duplicate of 67976 ***

Note You need to log in before you can comment on or make changes to this bug.