Bug 680570 - multihead setup: xrandr (cli) fails to turn off monitor
Summary: multihead setup: xrandr (cli) fails to turn off monitor
Keywords:
Status: CLOSED DUPLICATE of bug 680569
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-25 22:48 UTC by Jaroslaw Gorny
Modified: 2018-04-11 13:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-02 11:30:35 UTC


Attachments (Terms of Use)
xrandr -v (6.47 KB, text/plain)
2011-02-25 22:48 UTC, Jaroslaw Gorny
no flags Details

Description Jaroslaw Gorny 2011-02-25 22:48:22 UTC
Created attachment 481100 [details]
xrandr -v

Description of problem:
Setup: LVDS + DVI, both turned on
Trying to turn off any of the monitors with xrandr fails.

Version-Release number of selected component (if applicable):
Software from: gfx_test_week_20110221_x86-64.iso

How reproducible:
Always

Steps to Reproduce:
1. have LVDS and DVI turned on.
2. use xrandr to turn off any of them (eg. "xrandr --output LVDS1 --off")
  
Actual results:
Both displays are blank for 1-2 seconds, then they are both turned on again.

Expected results:
Display specified with "--output" option should be turned off.

Additional info:
1. External monitor (DVI) connected via docking station.
2. Smolt profile:
http://www.smolts.org/client/show/pub_55f01737-29ac-4707-9ea9-b53af748da2b
3. xrandr -v results in attachment.

Comment 1 Matěj Cepl 2011-02-28 20:26:01 UTC
Is this a duplicate of bug 680569 just in other direction? (switching off monitor instead of the notebook's display)

Comment 2 Jaroslaw Gorny 2011-02-28 20:44:47 UTC
No. It's not I believe. #680569 is about problems when using GUI tool. This one is about running xrandr from command line.
And the behaviour is slightly different here. 'xrandr' from CLI simply does NOT turn off any monitor, while GUI tool (#680569) turns them BOTH, no matter which one I want to.

Comment 3 Matěj Cepl 2011-02-28 23:53:12 UTC
well, it could be the same ... we just don't recognize what is LCD and what monitor. anyway, I'll keep these bugs open.

Please add drm.debug=0x04 to the kernel command line, and attach (if you are able to collect them)

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 4 Jaroslaw Gorny 2011-03-01 14:19:07 UTC
I've just uploaded all the logs in #680569.
And I think you're most probably right -  both cases are caused by the same issue.

Comment 5 Matěj Cepl 2011-03-02 11:30:35 UTC
I think I'll rather close this one. If there is anything terribly relevant in this case, we can reopen it anytime.

*** This bug has been marked as a duplicate of bug 680569 ***


Note You need to log in before you can comment on or make changes to this bug.