Bug 68061 - autoheader-2.13 in autoconf213 gives error message about needing a higher version of autoconf
autoheader-2.13 in autoconf213 gives error message about needing a higher ver...
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: autoconf213 (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-05 19:53 EDT by Nathan G. Grennan
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-11 02:38:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2002-07-05 19:53:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020625

Description of problem:
I was trying to build a package that was built to work with autoconf-2.13 and
automake-1.4. So I modify macros/autogen.sh to use the renamed older versions.
When I then run ./autogen.sh  I get the error message below which comes out of
autoheader or something it is calling.

Running autoheader...
FATAL ERROR: Autoconf version 2.52 or higher is required for this script
Running automake --gnu  ...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Modify macros/autogen.sh
2. ./autogen.sh

	

Actual Results:  Running autoheader...
FATAL ERROR: Autoconf version 2.52 or higher is required for this script
Running automake --gnu  ...

Expected Results:  Running autoheader...
Running automake --gnu  ...


Additional info:
Comment 1 Jens Petersen 2002-07-08 01:35:42 EDT
Can you tell me how to reproduce this?
If you could either write an exact sequence of command to
reproduce this or tell me which package/project is giving you
trouble, that would help.
Comment 2 Nathan G. Grennan 2002-07-08 02:34:27 EDT
Download http://www.okcforum.org/gtele_applet-0.2.tar.gz

Then downgrade gettext from 0.11.2-3 to 0.10.38-7 from RedHat 7.3. This is
required because the package is incompatiable with the newer gettext. I have
found other packages that are incompatiable with the newer gettext, but have
also found yet others who are incompatiable with the old version. One of the
packages that has a problem with 0.11.2-3 is galeon 1.2 cvs. IMHO gettext is
currently just a mess.

tar -zxf gtele_applet.tar.gz
cd gtele_applet-0.2
./autogen.sh

At this point you may have to meet certain dependencies. I am not sure what they
might be, I have my system setup with a number of changes.


Unmodified macros/autogen.sh

autoheader: autom4te-2.53 failed with exit status: 1
 at /usr/bin/autoheader line 163
**Error**: autoheader failed.


automake changed to be automake-1.4 in macros/autogen.sh  This alone works with
galeon-1.2.5-3   If you look into the spec file for it you will see automake is
set to automake-1.4 but  autoconf  is left as autoconf

autoheader: autom4te-2.53 failed with exit status: 1
 at /usr/bin/autoheader line 163
**Error**: autoheader failed.


automake changed to be automake-1.4 and autoconf to autoconf-2.13 in
macros/autogen.sh

autoheader: autom4te-2.53 failed with exit status: 1
 at /usr/bin/autoheader line 163
**Error**: autoheader failed.



automake changed to be automake-1.4  autoconf to autoconf-2.13  and autoheader
to autoheader-2.13 in macros/autogen.sh

Running autoconf ...
FATAL ERROR: Autoconf version 2.52 or higher is required for this script
**Error**: autoconf failed.
Comment 3 Nathan G. Grennan 2002-07-08 02:50:18 EDT
One other way   automake as automake-1.4   autoconf as autoconf and autoheader
as autoheader-2.13

Running autoheader...
FATAL ERROR: Autoconf version 2.52 or higher is required for this script
Running automake --gnu  ...
automake: configure.in: installing `./install-sh'
automake: configure.in: installing `./mkinstalldirs'
automake: configure.in: installing `./missing'
automake: configure.in: installing `./config.guess'
automake: configure.in: installing `./config.sub'
automake: Makefile.am: installing `./INSTALL'
automake: Makefile.am: installing `./COPYING'
configure.in: 834: required file `./_AM_File,.in' not found
configure.in: 834: required file `./[$2],.in' not found
configure.in: 834: required file `./[$3])].in' not found
Running autoconf ...
configure.in:31: error: AM_CONDITIONAL: invalid condition: FALSE
aclocal.m4:757: AM_CONDITIONAL is expanded from...
configure.in:31: the top level
**Error**: autoconf failed.




Removing the new and restoring the old works.

rpm -e --nodeps automake automake14 autoconf autoconf213
rpm -i automake-1.4p5-4.noarch.rpm autoconf-2.13-17.noarch.rpm




Comment 4 Jens Petersen 2002-07-10 04:32:11 EDT
[Btw the version of gettext in RHL7.3 is gettext-0.11.1-2.]

What happens if you also replace "aclocal" by "aclocal-1.4" in
autogen.sh?
Comment 5 Nathan G. Grennan 2002-07-10 08:23:09 EDT
With automake-1.4, autoheader-2.13, aclocal-1.4, and autoconf it works.
Comment 6 Jens Petersen 2002-07-11 02:14:41 EDT
autogen.sh is not a part of Autotools, so I don't see what can be
done to fix all the autogen.sh scripts floating around out there.
Not sure if it makes any sense to include a fixed autogen.sh
somewhere, since autogen.sh is deprecated anyway (these days
autoreconf should be used instead) and also there are
potentially too many version permutations.  I could imagine
also that some of the autogen.sh scripts have been tweaked in some
way, so there are several slightly different "autogen.sh" perhaps?
Comment 7 Nathan G. Grennan 2002-07-11 02:38:20 EDT
I am no autoconf/autogen/automake/autoheader/aclocal expert. Personally I would
say close this bug as NOTABUG. I was overlooking changing aclocal, because it
didn't start with the word auto. I don't consider it a problem that autogen.sh
has to be tweaked, as long as it can always be tweaked to work with avaiable tools.
Comment 8 Jens Petersen 2002-07-11 22:12:47 EDT
S'pose if autogen.sh weren't deprecated it might be worth updaing
it to use the environment variables AUTOCONF, AUTOMAKE, ACLOCAL,
LIBTOOL, etc.

Note You need to log in before you can comment on or make changes to this bug.