Bug 680647 - qt: Local file conflict with packages on update
qt: Local file conflict with packages on update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
14
i386 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 682010 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-26 12:45 EST by David
Modified: 2013-01-10 01:29 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-14 06:45:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David 2011-02-26 12:45:09 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.started software update
2.clicked install updates
3.
  
Actual results:


Expected results:


Additional info:
Test Transaction Errors:   file /usr/lib/qt4/plugins/designer/libphononwidgets.so from install of qt-designer-plugin-phonon-1:4.7.1-17.fc14.i686 conflicts with file from package qt-x11-1:4.7.1-7.fc14.i686
Comment 1 Kevin Kofler 2011-02-28 11:25:38 EST
qt-x11 should get upgraded too, why is it not? Is that a PackageKit or yum bug?
Comment 2 Rex Dieter 2011-02-28 11:33:47 EST
designer-plugin-phonon indeed has this dep:
Requires: %{name}-x11%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}

so qt-x11-4.7.1-17 should've been pulled into the transaction.
Comment 3 Kevin Kofler 2011-03-04 11:54:09 EST
*** Bug 682010 has been marked as a duplicate of this bug. ***
Comment 4 Rex Dieter 2011-03-04 11:57:20 EST
How are you updating?  yum?  packagekit?  other?
Comment 5 Rex Dieter 2011-03-04 12:41:03 EST
OK, looks like both cases were packagekit.
Comment 6 Rex Dieter 2011-04-01 14:53:29 EDT
* Fri Mar 25 2011 Rex Dieter <rdieter@fedoraproject.org> 1:4.7.2-6
- drop qt-designer-plugin-phonon

(this piece will be moved to phonon packaging soon)

Note You need to log in before you can comment on or make changes to this bug.