This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 68065 - Upgrade removes printer definition from printcap
Upgrade removes printer definition from printcap
Status: CLOSED DUPLICATE of bug 68255
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-05 20:55 EDT by timothy covell
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-09 20:09:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description timothy covell 2002-07-05 20:55:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-5.58 i686; Nav)

Description of problem:
Printing does not work after upgrade from 7.2 or 7.3.  Had working HP LJ1200
working under 7.3 but after upgrade /etc/printcap was empty and printing failed.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade to Limbo
2. Try to print
3. Try to configure a printer
	

Actual Results:  Printing does not work anymore	

Expected Results:  Printing should have continued with my previous configuration
or should have been switched to a new configuration.

Additional info:

 I copied over the old printcap to the new printcap, but it still failed to
work.  Also, I had to hand load the parport modules.  I'm still trying to get it
to work.   Finally, redhat-config-printer-gui crashes/never starts and
redhat-config-printer-tui crashes with:

Initializing alchemist edit environment ...
Initializing linux printing database ...
Can't locate Foomatic/Defaults.pm in @INC (@INC contains:
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at
/usr/bin/foomatic-configure line 13.
BEGIN failed--compilation aborted at /usr/bin/foomatic-configure line 13.
Traceback (most recent call last):
  File "/usr/sbin//redhat-config-printer-tui", line 8, in ?
    printconf_tui.startup_and_find_cmd()
  File "/usr/share/printconf/util/printconf_tui.py", line 2086, in
startup_and_find_cmd
    main.cmd_handlers[cmd]()
  File "/usr/share/printconf/util/printconf_tui.py", line 1954, in tui_main_run
    foomatic_init_overview()
  File "/usr/share/printconf/util/printconf_conf.py", line 1322, in
foomatic_init_overview
    root = parser.parse(foo.fromchild)
  File
"/usr/src/build/121260-i386/install/usr/lib/python2.2/site-packages/_xmlplus/utils/qp_xml.py",
line 134, in parse
xml.parsers.expat.ExpatError: no element found: line 1, column 0
Comment 1 Tim Waugh 2002-07-08 05:43:53 EDT
What does 'rpm -q pygtk2 python perl' say?
Comment 2 Tim Waugh 2002-07-08 12:22:21 EDT
Reproduced.  This is due to an anaconda/rpm bug (not all packages are upgraded).  Fresh 
Limbo installs should work though.
Comment 3 Jeremy Katz 2002-07-09 20:57:22 EDT

*** This bug has been marked as a duplicate of 68255 ***
Comment 4 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.