Bug 68094 - RFE: update X configuration test screen
RFE: update X configuration test screen
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: Xconfigurator (Show other bugs)
limbo
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
: FutureFeature
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-06 04:10 EDT by Thomas M Steenholdt
Modified: 2007-04-18 12:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 05:23:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xtest - GTK2 version with updated images (deleted)
2002-07-31 04:09 EDT, Thomas M Steenholdt
no flags Details
Xtest - GTK2 version with updated images (deleted)
2002-07-31 04:09 EDT, Thomas M Steenholdt
no flags Details
Xtest - GTK2 version with updated images (deleted)
2002-07-31 04:12 EDT, Thomas M Steenholdt
no flags Details
Xtest - GTK2 version with new images (deleted)
2002-07-31 06:42 EDT, Thomas M Steenholdt
no flags Details
updated version, fixes a problem with non-transparent png's(correct way to get root window pixmap) + addes a quick-and-dirty history block at top to better track changes (68.73 KB, application/octet-stream)
2002-08-13 05:23 EDT, Thomas M Steenholdt
no flags Details
updated Xtest tool (61.21 KB, application/octet-stream)
2002-08-20 17:59 EDT, Thomas M Steenholdt
no flags Details
Here's the latest tarball with new graphics. Could you set "#65779C" {101,119,156} (a blue color) as the background? (48.70 KB, application/octet-stream)
2002-08-20 19:07 EDT, Garrett LeSage
no flags Details
Yep - It's done! (47.82 KB, application/octet-stream)
2002-08-21 06:03 EDT, Thomas M Steenholdt
no flags Details
Anyways here it comes - this way i'll be able to sleep at night ;o) - I named it 2.0.3 to be able to tell them all apart, please rename to whatever you see fit! (45.96 KB, application/octet-stream)
2002-09-17 07:43 EDT, Thomas M Steenholdt
no flags Details

  None (edit)
Description Thomas M Steenholdt 2002-07-06 04:10:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020625

Description of problem:
The installer has gotten a really great new look and feel and the only thing
that sticks out is the old Gnome 1.x desktop used for X configuration test
screen... Why not put another type of image in here instead, to acommodate the
rest of the installers beautiful new look

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Press test on the X configuration page
2.Watch the outdated desktop that pops up
3.
	

Additional info:
Comment 1 Michael Fulbright 2002-07-09 20:05:56 EDT
This program is part of Xconfigurator.
Comment 2 Mike A. Harris 2002-07-19 06:56:13 EDT
Xconfigurator is no longer part of Red Hat Linux, having been
replaced now with redhat-config-xfree86

Otherwise, the suggestion would be a very good idea.  ;o)
Comment 3 Thomas M Steenholdt 2002-07-19 08:32:27 EDT
does this mean, that the test screen the user is presented with during the
installation is NOT the old "Gnome 1.x desktop screenshot" any longer??? This is
in fact what I was trying to request ;)
Comment 4 Mike A. Harris 2002-07-19 12:41:04 EDT
Actually... that is a program called Xtest, which we just realized is still
needed currently.  It has not been updated to GNOME 2 yet.  I'm reopening
this so it can be tracked again.

Can someone update the graphic images for GNOME 2, etc..  I created a new
CVS module on elvis called Xtest if you'd like to update it, or you can
send me the new graphics.  I'd do it myself, but I'm no artist, and I'm not
very handy with gimp et al.  10 thumbs.  ;o)
Comment 5 Mike A. Harris 2002-07-26 05:57:05 EDT
Lemme know if any of you plan on doing this for Milan, or if it should
be deferred for a future release.  It'd be nice to get it into Milan,
however as I said above, I'm not a graphic artist, so someone else
should claim this one if possible.
Comment 6 Thomas M Steenholdt 2002-07-26 08:10:18 EDT
Will You port the Xtest program to GTK2?

I'll start working on the images needed...
Comment 7 Mike A. Harris 2002-07-26 13:18:05 EDT
Someone fluent in GTK/GTK2 will have to port it to GTK2.

I don't know GTK all that well, and spend 99% of my time hacking on X.
I just happened to get stuck with Xconfigurator/Xtest, and it stuck.

;o)

I'm happy with it the way it is personally.
Comment 8 Thomas M Steenholdt 2002-07-31 04:17:05 EDT
I have an updated package source for you - GTK2 version of Xtest with new images.

However I'm getting a database error when trying to attach it! Is there some
other way you want me to send it to you? (i already notified bugzilla@redhat.com
about the problem)

Anyway - When you get the package, please test it to make sure it behaves the
way it's supposed to... It work like a charm on my machine.
Comment 9 Mike A. Harris 2002-07-31 06:36:09 EDT
Fantastic!

There were technical difficulties with bugzilla tonight.  Could you please
try to attach it again, or else email it to me: mharris@redhat.com

Thanks.
Comment 10 Thomas M Steenholdt 2002-07-31 06:43:04 EDT
attachment failed... You can expect an email any minute!!!
Comment 11 Thomas M Steenholdt 2002-08-13 05:23:46 EDT
Created attachment 70264 [details]
updated version, fixes a problem with non-transparent png's(correct way to get root window pixmap) + addes a quick-and-dirty history block at top to better track changes
Comment 12 Mike A. Harris 2002-08-15 23:31:39 EDT
Built in rawhide as Xtest-2.0-1

Thanks for the package updates!
Comment 13 Thomas M Steenholdt 2002-08-20 17:59:15 EDT
Created attachment 71744 [details]
updated Xtest tool
Comment 14 Thomas M Steenholdt 2002-08-20 18:04:17 EDT
updated the package for speed and usability...

desktop icon image has been stripped off one icon, to have it small enough to
show nicely on 640x480

all panel images have been stripped off the alpha channel for speed improvement
(same goes for the dynamically created middle panel pixbuf)

drawing sequence have been reordered, to better imitate real world os behaviour.
when desktop images goes below the panel, they are no longer drawed on top of
the panel image.

Hope you like it
Comment 15 Garrett LeSage 2002-08-20 19:07:30 EDT
Created attachment 71784 [details]
Here's the latest tarball with new graphics. Could you set "#65779C" {101,119,156} (a blue color) as the background?
Comment 16 Thomas M Steenholdt 2002-08-21 06:03:10 EDT
Created attachment 71866 [details]
Yep - It's done!
Comment 17 Thomas M Steenholdt 2002-08-21 06:05:52 EDT
So the new tarball also contains a change that eliminates the sense of the
incomplete panel, as Xtest start up... The middle panel is tiled across the
entire screen width, then the other panel pics are drawn on top of that... Looks
a lot better...
Comment 18 Thomas M Steenholdt 2002-08-21 06:07:29 EDT
Oh, and I removed the alpha channel on one of the panel images... It feels like
non alpha images are somewhat quicker than the alpha ones... sorry, I forgot this!
Comment 19 Thomas M Steenholdt 2002-09-16 07:37:11 EDT
I've made another couple of changes to Xtest regarding the way the panel image
is constructed... It now all of the panel pieces into one dynamically
constructed panel pixbuf which is then rendered onto the desktop... This is a
much nicer way of eliminating the incomplete panel problem and this would even
work with transp. panel images if that should ever become interesting. Seems
even faster too...

Do you want the update?

Should I post it elsewhere for you to get it?

Any other changes since my last submission, that I should know about? (new
images - new color - anything like that)
Comment 20 Thomas M Steenholdt 2002-09-17 07:43:50 EDT
Created attachment 76367 [details]
Anyways here it comes - this way i'll be able to sleep at night ;o) - I named it 2.0.3 to be able to tell them all apart, please rename to whatever you see fit!
Comment 21 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.