Bug 68101 - ifup modprobes nonexisting devices
Summary: ifup modprobes nonexisting devices
Status: CLOSED DUPLICATE of bug 68127
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: net-tools (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-06 11:32 UTC by Thomas M Steenholdt
Modified: 2015-03-05 01:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-06 11:32:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas M Steenholdt 2002-07-06 11:32:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
when running an "ifup eth0" command on a system with one ethernet controller
installed takes a few seconds. When checking the log (/var/log/messages)
afterwards it has modprobe errors like this:

Jul  5 20:44:10 niles modprobe: modprobe: Can't locate module eth1
Jul  5 20:44:10 niles modprobe: modprobe: Can't locate module eth2
Jul  5 20:44:10 niles modprobe: modprobe: Can't locate module eth3
Jul  5 20:44:10 niles modprobe: modprobe: Can't locate module eth4
Jul  5 20:44:10 niles modprobe: modprobe: Can't locate module eth5
Jul  5 20:44:10 niles modprobe: modprobe: Can't locate module eth6
Jul  5 20:44:10 niles modprobe: modprobe: Can't locate module eth7
Jul  5 20:44:13 niles dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Jul  5 20:44:13 niles dhclient: DHCPACK from 10.1.1.1
Jul  5 20:44:13 niles dhclient: bound to 10.1.1.254 -- renewal in 81671 seconds.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.make sure your eth0 is not up then
2.ifup eth0
3.tail -n 20 /var/log/messages
	

Actual Results:  looks like somehow the ifup command triggers a probe of eth0-7,
although only eth0 was specified on command line and all the others are non-existing

Expected Results:  no modprobe errors should have been reported - the ifup
should not modprobe devices it is not asked to configure

Additional info:

Comment 1 Bill Nottingham 2002-07-08 05:38:24 UTC

*** This bug has been marked as a duplicate of 68127 ***


Note You need to log in before you can comment on or make changes to this bug.