Bug 68102 - sendmail startup produces error after installation
sendmail startup produces error after installation
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-06 07:38 EDT by Thomas M Steenholdt
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-26 13:06:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas M Steenholdt 2002-07-06 07:38:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
At the first reboot after installation, at sendmail startup, an error regarding
"virtusertable.db" is displayed saying "clock skew detected - build may be
incomplete"

It tried rebooting immediately to see if this was a one timer - but it showed again.
After having my system running for some time, the error message is no longer
producet at boot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install RH Limbo
2.watch the screen as services are starting noticing the sendmail error
3.
	

Actual Results:  An error is displayed on the screen

Expected Results:  No error should be displayed on the screen

Additional info:
Comment 1 Florian La Roche 2002-07-11 07:21:06 EDT
I think this is due to the timesettings during installation. Any
recommondations on how this should be fixed?

greetings,

Florian La Roche
Comment 2 Peter van Egdom 2002-08-01 14:58:03 EDT
I've experienced a similar problem. Here's my timezone configuration :

[peterve@limbo-pc /]$ cat /etc/sysconfig/clock
ZONE="Europe/Amsterdam"
UTC=false
ARC=false

When I first booted Red Hat Linux - Limbo (beta 2) 7.3.93, I got the message

"Sendmail.cf heeft een wijzigingstijd in de toekomst
  (2002-07-31 00:08:54 > 2002-07-30 22:52:28) Your build may be incomplete."

(which means in English : Sendmail.cf has a modification time in the future..."

It looks like the "sendmail.cf" file is being generated from the "sendmail.mc"
file during installation.

My guess is that this generation of "sendmail.cf" takes probably place before
the timezone configuration screen, which cause the warning during the first boot.

The second time when booted, some time has passed and the system time has passed
the modification time of "sendmail.cf".

Time can be a strange experience. :-)
Comment 3 Jeremy Katz 2002-08-19 14:47:24 EDT
We can't change this this late in the release cycle.  Will revisit setting time
during the install for a future release
Comment 4 Peter van Egdom 2002-10-29 16:57:44 EST
Bug still occurs with Red Hat Linux 8.0.
Please reopen and assign bug to product Red Hat Linux 8.0.
Comment 5 Jeremy Katz 2003-02-26 13:06:44 EST
Should be happier in our current betas.
Comment 6 Thomas M Steenholdt 2003-02-26 13:42:47 EST
I havn't seen this in Phoebe, I would have noticed! Thanks!

Note You need to log in before you can comment on or make changes to this bug.