Bug 68103 - Unable to recompile Evolution
Unable to recompile Evolution
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: evolution (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-06 09:20 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-06 09:23:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
compiler output (compressed with gzip) (812.60 KB, application/octet-stream)
2002-07-06 09:22 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-07-06 09:20:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
Can't rebuild the evolution src package included on CD #4 of the Limbo set. Only
try to do this because of the bug in the distributed binary which causes a seg
fault when marking messages as read or unread.

Also, there is a dependancy missing, as the recompile requires the openldap-dev
package but doesn't tell you.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpmbuild --rebuild evolution-1.0.7-2.src.rpm
2.
3.
	

Actual Results:  The compilation seems to proceed properly, but then gets stuck
in an infinite loop (or a very long one) when processing xml.

Expected Results:  The compile should have completed successfully, and an
installable RPM produced.

Additional info:
attached file is the compile output
Comment 1 Need Real Name 2002-07-06 09:22:54 EDT
Created attachment 63984 [details]
compiler output (compressed with gzip)
Comment 2 Jeremy Katz 2002-07-06 13:31:03 EDT
Rebuilding won't fix the right click problem (it also happens in the 1.0.8
packages currently in rawhide).  The xml processing takes a while because of
perl being slow to do UTF8 string splitting... should be improved with the
rawhide perl.  Added openldap-devel to the buildrequires

Note You need to log in before you can comment on or make changes to this bug.