Bug 681220 - Starting of a virtual machine ends with qemu-kvm: /builddir/build/BUILD/qemu-kvm-0.14.0/qemu-kvm.c:1724: kvm_mutex_unlock: Assertion `!cpu_single_env' failed.
Summary: Starting of a virtual machine ends with qemu-kvm: /builddir/build/BUILD/qemu-...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Justin M. Forbes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 676946 677169 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-01 13:44 UTC by Matěj Cepl
Modified: 2018-04-11 07:08 UTC (History)
23 users (show)

Fixed In Version: qemu-0.14.0-4.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-23 05:02:28 UTC


Attachments (Terms of Use)
/var/log/libvirt/qemu/tikanga.log (86.42 KB, text/plain)
2011-03-01 13:44 UTC, Matěj Cepl
no flags Details
output of virsh dumpxml tikanga (1.78 KB, text/plain)
2011-03-01 13:44 UTC, Matěj Cepl
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 723871 None None None Never

Description Matěj Cepl 2011-03-01 13:44:00 UTC
Created attachment 481618 [details]
/var/log/libvirt/qemu/tikanga.log

Description of problem:
When running RHEL-5 VM in the Rawhide KVM, I get the attached log and there is no VM running anymore.

Version-Release number of selected component (if applicable):
qemu-kvm-0.14.0-0.1.201102107aa8c46.fc16.x86_64
2.6.38-0.rc6.git6.1.fc15.x86_64

How reproducible:
2 out of 2
  
Actual results:
no machine running

Expected results:
maching running

Comment 1 Matěj Cepl 2011-03-01 13:44:36 UTC
Created attachment 481619 [details]
output of virsh dumpxml tikanga

Comment 2 Matěj Cepl 2011-03-01 14:54:03 UTC
Patch is available in http://patchwork.ozlabs.org/patch/84704/

Comment 3 Julian Sikorski 2011-03-04 21:55:29 UTC
*** Bug 676946 has been marked as a duplicate of this bug. ***

Comment 4 Julian Sikorski 2011-03-04 21:56:38 UTC
https://koji.fedoraproject.org/koji/getfile?taskID=2885630&name=build.log
qemu does not build with that patch applied.

Comment 5 Ian Pilcher 2011-03-07 17:02:17 UTC
The package does build if "--with x86only" is added to the rpmbuild command.
I'm not familiar with the qemu build process, so I can't say whether this is
just a build process issue or a more fundamental problem.

Comment 6 Ian Pilcher 2011-03-07 22:19:55 UTC
*** Bug 677169 has been marked as a duplicate of this bug. ***

Comment 7 Ian Pilcher 2011-03-15 03:22:58 UTC
I am able to build the full set of qemu packages with this patchset:

  http://permalink.gmane.org/gmane.linux.redhat.fedora.virtualization/998

SPICE is working with a Windows 7 guest.

Comment 8 Fedora Update System 2011-03-17 15:40:15 UTC
qemu-0.14.0-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/qemu-0.14.0-3.fc15

Comment 9 Mark Chandler 2011-03-18 00:21:57 UTC
Using qemu-0.14.0-3 from the fedora-virt-preview repo on F14.
Loading the QXL (0.6.1) drivers onto an XP VM still crashes qemu-kvm with the following message in the VM's log:
"qemu-kvm: /builddir/build/BUILD/qemu-kvm-0.14.0/qemu-kvm.c:1724: kvm_mutex_unlock: Assertion `!cpu_single_env' failed."

Comment 10 Fedora Update System 2011-03-18 15:20:14 UTC
qemu-0.14.0-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/qemu-0.14.0-4.fc15

Comment 11 Mark Chandler 2011-03-19 06:36:40 UTC
Works for me now. Windows XP SP3 VM loads the 0.6.1 drivers without crashing.

Comment 12 Julian Sikorski 2011-03-19 10:52:22 UTC
Win 7 Pro works as well - I am testing using the packages from virt-preview repo.

Comment 13 Fedora Update System 2011-03-23 05:02:20 UTC
qemu-0.14.0-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.