Bug 68127 - ifup goes through eth0 - eth7
ifup goes through eth0 - eth7
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: initscripts (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 68101 69786 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-06 15:15 EDT by Tammy Fox
Modified: 2014-03-16 22:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-20 23:44:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tammy Fox 2002-07-06 15:15:38 EDT
From /var/log/messages:

Jul  6 14:57:25 goofy network: Setting network parameters:  succeeded 
Jul  6 14:57:26 goofy network: Bringing up loopback interface:  succeeded 
Jul  6 14:57:26 goofy ifup:  
Jul  6 14:57:26 goofy ifup: Determining IP information for eth0... 
Jul  6 14:57:28 goofy modprobe: modprobe: Can't locate module eth1 
Jul  6 14:57:28 goofy modprobe: modprobe: Can't locate module eth2 
Jul  6 14:57:28 goofy modprobe: modprobe: Can't locate module eth3 
Jul  6 14:57:28 goofy modprobe: modprobe: Can't locate module eth4 
Jul  6 14:57:28 goofy modprobe: modprobe: Can't locate module eth5 
Jul  6 14:57:28 goofy modprobe: modprobe: Can't locate module eth6 
Jul  6 14:57:28 goofy modprobe: modprobe: Can't locate module eth7 
Jul  6 14:57:34 goofy dhclient: DHCPACK from 192.168.100.254 
Jul  6 14:57:34 goofy ifup:  done. 
Jul  6 14:57:34 goofy network: Bringing up interface eth0:  succeeded 

Is the ifup script supposed to go through all ethernet cards even if they don't
exist in the system? I don't see this on a Valhalla box.
Comment 1 Nathan G. Grennan 2002-07-07 18:43:17 EDT
Reproduced, I see this in my /var/log/messages when running ifup with dhcp.


Jul  6 12:41:17 cygnusx-1 ifup:  
Jul  6 12:41:27 cygnusx-1 kernel: Partition check:
Jul  6 12:41:17 cygnusx-1 ifup: Determining IP information for eth0... 
Jul  6 12:41:27 cygnusx-1 kernel:  hde: hde1 hde2 hde3
Jul  6 12:41:19 cygnusx-1 modprobe: modprobe: Can't locate module eth2 
Jul  6 12:41:27 cygnusx-1 kernel:  hdg: hdg1
Jul  6 12:41:19 cygnusx-1 modprobe: modprobe: Can't locate module eth3 
Jul  6 12:41:27 cygnusx-1 kernel:  hdh: hdh1
Jul  6 12:41:19 cygnusx-1 modprobe: modprobe: Can't locate module eth4 
Jul  6 12:41:27 cygnusx-1 kernel: Linux Tulip driver version 0.9.15-pre10 (Mar
8, 2002)
Jul  6 12:41:19 cygnusx-1 modprobe: modprobe: Can't locate module eth5 
Jul  6 12:41:27 cygnusx-1 kernel: PCI: Found IRQ 10 for device 00:0f.0
Jul  6 12:41:19 cygnusx-1 modprobe: modprobe: Can't locate module eth6 
Jul  6 12:41:27 cygnusx-1 kernel: PCI: Sharing IRQ 10 with 00:0d.0
Jul  6 12:41:19 cygnusx-1 modprobe: modprobe: Can't locate module eth7 
Jul  6 12:41:27 cygnusx-1 kernel: eth0: ADMtek Comet rev 17 at 0xd800,
FA:50:FA:50:FA:50, IRQ 10.
Jul  6 12:41:19 cygnusx-1 ifup:  done. 

Comment 2 Bill Nottingham 2002-07-08 01:38:20 EDT
*** Bug 68101 has been marked as a duplicate of this bug. ***
Comment 3 Jay Turner 2002-07-25 08:49:57 EDT
*** Bug 69786 has been marked as a duplicate of this bug. ***
Comment 4 Thomas M Steenholdt 2002-07-31 01:48:15 EDT
This bug is still valid in RH Limbo 7.3.93
Comment 5 Bill Nottingham 2002-08-20 23:44:34 EDT
Woops. Fixed in initscripts-6.91-1.
Comment 6 Jay Turner 2002-08-21 12:01:30 EDT
Fix confirmed with initscripts-6.91-1.

Note You need to log in before you can comment on or make changes to this bug.