Bug 68137 - lm_sensors RPM is 2.6.3 (good) but kernel patched with 2.6.1 (bad)
Summary: lm_sensors RPM is 2.6.3 (good) but kernel patched with 2.6.1 (bad)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel
Version: limbo
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-06 20:19 UTC by Brian Stretch
Modified: 2007-04-18 16:43 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2002-07-06 20:19:53 UTC


Attachments (Terms of Use)

Description Brian Stretch 2002-07-06 20:19:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
From my /var/log/messages:

Jul  6 15:34:50 shotgun kernel: i2c-proc.o version 2.6.1 (20010825)
Jul  6 15:36:17 shotgun kernel: i2c-amd756.o version 2.6.1 (20010830)
Jul  6 15:36:17 shotgun kernel: i2c-amd756.o: Error: Can't detect AMD756,
function 3!
Jul  6 15:36:17 shotgun kernel: i2c-amd756.o: AMD756/766 not detected, module
not inserted.

# rpm -q lm_sensors
lm_sensors-2.6.3-2

2.6.3 is needed to detect the AMD768 chipset properly. Bug 65045 documents this
for RH7.3, "the newer lm_sensors changes the kernel<->userspace interface a bit,
not something we can do within a release".  Now you can :-).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.modprobe i2c-amd756
2.
3.
	

Actual Results:  /lib/modules/2.4.18-5.58smp/kernel/drivers/i2c/i2c-amd756.o:
init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.18-5.58smp/kernel/drivers/i2c/i2c-amd756.o: insmod
/lib/modules/2.4.18-5.58smp/kernel/drivers/i2c/i2c-amd756.o failed
/lib/modules/2.4.18-5.58smp/kernel/drivers/i2c/i2c-amd756.o: insmod i2c-amd756
failed


Additional info:

Comment 1 Arjan van de Ven 2002-07-06 20:23:59 UTC
Just try the 2.4.18-5.61 kernel from rawhide :)


Note You need to log in before you can comment on or make changes to this bug.